FlightAware Discussions

Dump1090exporter doesn't work

My installation is on Ubuntu 20.04 LTS, Python 3.8.
I installed exporter using pip command

sudo pip install dump1090exporter

and I have an error when I start the exporter:

Who knows how to avoid (or repair) this error?

Exporter version: dump1090exporter-21.0.0

try it again this time with sudo pip3 install…

Nothing was changed, still the same error.

ImportError: cannot import name ‘Service’ from ‘aioprometheus’ (/usr/local/lib/python3.8/dist-packages/aioprometheus/init.py)

Is any other method to instal dump1090exporter than by pip?

As it is python, you can try to run the .py file provided on Github:

I already tried it, the same result. I don’t know what happened. The error message doesn’t give directions to solve the problem. I installed ubuntu from scratch two days ago and after that, I can’t instal dump1090exporter. In the older installation, it worked perfectly. I think something is missing in my environment but I don’t know what.

The error message indicates it’s not dump1090exporter but something with that aioprometheus.

Have you tried reinstalling that?

This has been updated a few days ago.
I’ve installed it several times and never had this issue and i was even not aware that this library is required

I had reinstalled aioprometheus but without any change. I rebooted the system, without any change too.
So I tried to reinstall only the component system. After that, I had that message:


I don’t understand that message. Is it “satisfied” or “does not provide”. Both can’t exist at the same time I think.

Yes, that seem to be a library issue. That goes beyond my skills

Maybe you ask in the Prometheus discussion board?

I’m going to do.
How to reproduce that issue?

  1. Install Ubuntu 20.04 from scratch.
  2. sudo apt update
  3. sudo apt install python3-pip
  4. sudo pip3 install dump1090exporter
  5. dump1090exporter

There is no difference if you use pip or pip3. In both cases, the result is the same, above error.

that’s really strange…

I am clueless about it.

I am clueless about it.

Me too :slight_smile:

A few days ago it worked well. Until I reinstalled ubuntu from scratch.

I think there is another way to install dump1090 exporter but I can’t recall that way. I remember when I installed it and when it worked very well then the installation messages were different from installation messages from pip(3).
Is there anybody who installed that exporter by method another than by pip(3)?

I set up a Grafana station about a year ago and i used the dump1090exporter.
I cannot remember that i used pip(3) for it. But i am getting old…