Dump1090(Mut) error correction giving issues feeding to PF?


#1

Evening gents,

My PlaneFinder feed is having errors connecting to the PF site.
Having emailed them, they suggest dump1090’s (i’m using Muatbility 1.14) error correction should be turned off, as a possible culprit.

They suggest turning off “-fix” and “-aggressive” (if they’re on - I’ll check when I get home).

Any thoughts - should I do this, what’s the impact?

Thanks,

C


#2

Definitely turn off --aggressive.
–fix doesn’t generally cause problems.


#3

i have aggressive turned on and all works fine


#4

You’re increasing the rate of bad data by turning on “aggressive”.


#5

I wonder if they have changed their data quality criteria recently. I had a similar problem a few weeks ago and they requested I turn off --fix. It does make a difference to the number of tracks recorded, but the reduction is primarily those with single messages which are far fewer than before. It doesn’t seem to make much difference to the number of aircraft seen or the message rate.


#6

Single message aircraft aren’t even forwarded fwiw (dump1090 waits for a second message before forwarding anything)


#7

Great - thanks for the details gents - I’ll update as per over the weekend.


#8

I am actually thinking of removing --aggressive from dump1090-mutability entirely - it feels a little wrong to do that, but it seems to be a magnet for people to turn on without understanding the consequences and then spewing bad data everywhere. Maybe I’ll make it a compile-time option to enable it.


#9

maybe too much cost - but aren’t mlat positions marked as ‘mlat’ … what about setting a marker ‘probably wrong’ in the position data output from aggressive …


#10

If you remove it, what happens to instances that include it in the command line? Maybe just code it as a NOOP?


#11

It’s really hard work trying to crowbar anything more into the beast protocol.


#12

i guessed that this were not so trivial. since i shut down my --aggressive flag on your request some weeks ago - i saw nearly zero decrease in real detected aircrafts - and won’t miss it. maybe simply deleting the dedicated mutability reconfigure-page for --aggressive would do 90% of the trick …


#13

For sure! I think that would be a positive improvement to your software.


#14

Was looking at my stats. Any chance that the aggressive mode isn’t as troublesome if the site has an amplifier and 1090Mhz filter?


#15

If anything, --aggressive is worse on amplified setups because the noise floor is being amplified too.