Dump1090-fa and Performance Graphs


#61

@Patrius

(1) At what address you are trying to see the map? Use following:

SkyView Map: http://ip-of-pi/dump1090-fa/

Graphs: http://ip-of-pi/graphs.php

Web Portal Admin: http://ip-of-pi/admin

(2) Clear browser cache (Ctrl+Shift+Delete) then Reload browser (Ctrl+F5)


#62

<IP_of_Pi>:8080 works too.


#63

All 3 links abcd567 mentioned worked

SoNic67 :
the link you mention, does not work (spinning wheel)

another question: the last screen in the admin section “maintenance” is that for purge the database of measurements when it becomes to big ?


#64

It looks like databse of flights, and NOT measurements.
Its size is 0 Mb in my install which is several months old, and I never purged it.


#65

I tried it in the past but the checkbox remains inactive even after date selections, so I think is activated only when ‘advanced features’ are selected and a db is created.


#66

Hi,
guys, I was (am ?:angry: ) stupid and forget the admin password of the adsb-receiver portal, any suggestions to get it back, reset password does not work because email in posix was never setup.
Thanks


#67

I did the same, however after a reboot I cannot acces trough ssh anymore.
Have about the same setup, this has happened before btw, I’m not sure why…

It, is also not feeding to flightaware what means that the rpi not totally booted.
Well think I have to redo the SD card LOL

I think I will instal strech and just let the script install everything, however it will have to wait since I don’t have it set up at my home


#68

Install Stretch is ok, but if you try to install dump1090-fa (or may be piaware, I dont remeber well) by script, it will fail, I mean if J Prochazka has not yet fixed a bug in it (it was failing when I tested last week).


#69

Then maybe it’s a better idee to just use the piaware img and then try to install the portal?
I like the graphs, but for some reason it screws up something I think, since I only use ssh and don’t have a monitor connected it’s kind of difficult to figure out what exactly is failing.

Maybe if I power it down it will come up again, but for now it seems it hangs somewhere at boot.


#70

Yes, this is an easy option.

Alternatively you can write Stretch image, then install piaware and dupm1090-fa as shown on this page, then run script to install portal.

http://flightaware.com/adsb/piaware/install


#71

So maybe you know this.

Let’s say I start with stretch lite.
The instal flighatware manual…

And then run the script for the portal.
Will the other feeder options work when using the script?
fr24 etc? Or is there something broken there too>?


#72

Hi,
I copied the /var/www/html directory and created a new empty /var/www/html and rerun the installation script of the adbs-receiver,
I had then again the initial screens, I have now copied the graphs directory from the original directory, so I don’t loose the past values, so far so good

I will report back when it has run a little longer

fingers crossed


#73

Anout 2 weeks ago when I tested the script, it installed feeders planefinder & flightradar24, AND web portal smoothly without any problem. The only things found broken were piaware and adsbexchange??? (not sure it was adsbexchange or dump978)


#74

Everything ok, problem solved


#75

The Problem

The Solution

Congratulations for finding the solution.
Great, very helpful for all.


#76

To come back to this and the solution.

I connected the Pi trough LAN and it booted just fine, the problem was that Wlan0 didn’t came up.
“Could not communicate with WLAN” etc.

No idee why this happened I’m not even sure if this is because of the script or a combination of experimentation before by myself.
The problem occurred after update/upgrade

Wel after some searching I found this to work
removed/installed wpasupplicant

sudo nano /etc/network/interfaces

adding this at the end

allow-hotplug wlan0
iface wlan0 inet manual
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

run

sudo systemctl enable wpa_supplicant.service

the reboot and it came upgain, rest is working fine now :slight_smile:


#77

Hi guys,
I looked in the syslog today and I see the following errors coming in every 30 sec

Sep 17 00:55:56 wezen rc.local[450]: usage: mlat-client [-h]
Sep 17 00:55:56 wezen rc.local[450]:                    [--input-type {radarcape_gps,auto,dump1090,avrmlat,beast,radarcape_12mhz,radarcape,sbs}]
Sep 17 00:55:56 wezen rc.local[450]:                    --input-connect INPUT_CONNECT [--results RESULTS]
Sep 17 00:55:56 wezen rc.local[450]:                    [--no-anon-results] [--no-modeac-results] --lat LAT --lon
Sep 17 00:55:56 wezen rc.local[450]:                    LON --alt ALT [--privacy] --user USER [--server SERVER]
Sep 17 00:55:56 wezen rc.local[450]:                    [--no-udp]
Sep 17 00:55:56 wezen rc.local[450]: mlat-client: error: argument --lat: expected one argument

I checked the program in /home/pi/adsb-receiver/build/adsbexchange/adsbexchange-mlat_maint.sh

#! /bin/sh
while true
  do
    sleep 30
    /usr/bin/mlat-client --input-type dump1090 --input-connect 127.0.0.1:30005 --lat  --lon  --alt 21 --user Flightaware_Pro_001 --server feed.adsbexchange.com:31090 --no-udp --results beast,connect,127.0.0.1:30104
  done

I see the lat and long are not defined

and in /usr/bin/mlat-clent I understand they are required


    location = parser.add_argument_group('Receiver location')
    location.add_argument('--lat',
                          type=options.latitude,
                          help="Latitude of the receiver, in decimal degrees. Required.",
                          required=True)
    location.add_argument('--lon',
                          type=options.longitude,
                          help="Longitude of the receiver, in decimal degrees. Required.",
                          required=True)
    location.add_argument('--alt',
                          type=options.altitude,
                          help="""
Altitude of the receiver (height above ellipsoid).  Required. Defaults to metres, but units may
specified with a 'ft' or 'm' suffix. (Except if they're negative due to option
parser weirdness. Sorry!)""",
                          required=True)

Would it be possible to check your setup ? I think something went wrong, I don’t think it’s the purpose to generate a lot of errors
But I nver got the question during the setup for coordinates or I missed it .(I mean during the setup for setting up the performance graphs.

Can I just put them in the adsbexchange-mlat_maint.sh? How is your setuo here ?
Thanks for any input.

PS : piaware status is ok :

PiAware master process (piaware) is running with pid 448.
PiAware ADS-B client (faup1090) is running with pid 817.
PiAware mlat client (fa-mlat-client) is running with pid 1079.
Local ADS-B receiver (dump1090-fa) is running with pid 442.

dump1090-fa (pid 442) is listening for connections on port 30005.
faup1090 is connected to the ADS-B receiver.
piaware is connected to FlightAware.

dump1090 is producing data on localhost:30005.


#78

you only get that question if you select a feeder (dump1090-fa or dump1090-mutability).

now if you go to your stats page as in this, top right corner just click on the gray ‘wheel’

in the next pop-up click the buttons to configure location and/or antenna elevation.


#79

There are 2 independent mlat clients.
fa-mlat-client - for flightaware mlat
mlat-client - for adsbexchange mlat

The mlat-maint script you have posted belongs to adsbexchange mlat. There is a bug in adsbexchange installation script by J Prochazka, which leaves the lat and lon values empty.

Whenever I install adsbexchange feeder using J Prochazka script, I always add these values manually by editing the file /home/pi/adsb-receiver/build/adsbexchange/adsbexchange-mlat_maint.sh


#80

@abcd567
Thank you, that was a kind of answer I expected, I will adopt the file