FlightAware Discussions

Dump1090-fa and Mlat not workingg anymore

Hello All,

Having problems. Installed MM2 and uninstalled it as wells described by ABCD567.
But now my dump1090-fa is not working and also Mlat is not enabled.
Could some one please help me?

tried to install tar1090
this outcome
pi@raspberrypi:~ sudo bash -c "(wget -nv -O - https://raw.githubusercontent.com/wiedehopf/tar1090/master/install.sh)"
2020-12-07 18:32:22 URL:https://raw.githubusercontent.com/wiedehopf/tar1090/master/install.sh [14803/14803] -> “-” [1]
remote: Enumerating objects: 91, done.
remote: Counting objects: 100% (91/91), done.
remote: Compressing objects: 100% (44/44), done.
remote: Total 46 (delta 12), reused 29 (delta 0), pack-reused 0
Unpacking objects: 100% (46/46), done.
From https://github.com/wiedehopf/tar1090-db

  • branch master -> FETCH_HEAD
  • 4de7584…2db85c3 master -> origin/master (forced update)
    HEAD is now at 2db85c3 db update
    remote: Enumerating objects: 191, done.
    remote: Counting objects: 100% (191/191), done.
    remote: Compressing objects: 100% (61/61), done.
    remote: Total 176 (delta 134), reused 157 (delta 115), pack-reused 0
    Receiving objects: 100% (176/176), 125.57 KiB | 824.00 KiB/s, done.
    Resolving deltas: 100% (134/134), completed with 15 local objects.
    From https://github.com/wiedehopf/tar1090
  • branch master -> FETCH_HEAD
    50ec99d…fea4e71 master -> origin/master
    HEAD is now at fea4e71 shuffle js loading order

FATAL: could not find aircraft.json in any of the usual places!
checked these: /run/readsb /run/dump1090-fa /run/dump1090 /run/dump1090-mutability /run/adsbexchange-feed /run/skyaware978

please check the result of
sudo systemctl status dump1090-fa

As you have also installed VRS it’s most likely that both are trying to use the same network port

8080 is used for dump1090-fa and this is the default port of VRS if you do not change it.
Please also check the output of

sudo systemctl status lighttpd

This is the webserver delivering the pages

You likely disabled the dump1090-fa service?
Are you sure you removed mm2?
Did you reboot?
Did you check the dump1090-fa log? https://github.com/wiedehopf/adsb-wiki/wiki/Debug-commands

You could always run this and it will likely fix it: https://github.com/wiedehopf/adsb-scripts/wiki/Automatic-installation-for-dump1090-fa

The instruction to Uninstall modesmixer2 at Github are as follows. These in no way can interfere or affect dump1990-fa, unless in these commands you have used dump1090-fa in place of mm2 and modesmixer2.


UNINSTALL

To completely remove configuration and all files, give following 5 commands:

sudo systemctl stop mm2 
sudo systemctl disable mm2 
sudo rm /lib/systemd/system/mm2.service 
sudo rm -rf /usr/share/mm2 
sudo rm /usr/bin/modesmixer2


@abcd567
I already did that. Today again:
pi@raspberrypi : ~ $ sudo systemctl stop mm2

Failed to stop mm2.service: Unit mm2.service not loaded.

**pi@raspberrypi** : **~ $** sudo systemctl disable mm2

Failed to disable unit: Unit file mm2.service does not exist.

**pi@raspberrypi** : **~ $** sudo rm /lib/systemd/system/mm2.service

rm: cannot remove '/lib/systemd/system/mm2.service': No such file or directory

**pi@raspberrypi** : **~ $** sudo rm -rf /usr/share/mm2

**pi@raspberrypi** : **~ $** sudo rm /usr/bin/modesmixer2

rm: cannot remove '/usr/bin/modesmixer2': No such file or directory

**pi@raspberrypi** : **~ $** 

To me it looks like I did it correct yesterday

@wiedehopf

I uninstalled MM2 correctly.

Did run your suggestions.

checked ««49.6
40# dump1090-fa configuration
# This is sourced by /usr/share/dump1090-fa/start-dump1090-fa as a
# shellscript fragment.

# If you are using a PiAware sdcard image, this config file is regenerated
# on boot based on the contents of piaware-config.txt; any changes made to this
# file will be lost.

# dump1090-fa won't automatically start unless ENABLED=yes
ENABLED=yes

RECEIVER_OPTIONS="--device-index 0 --gain 49.6  --ppm 0 --net-bo-port 30005"
DECODER_OPTIONS="--lat 52.509058 --lon 6.110759 --max-range 360 --fix"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 $
JSON_OPTIONS="--json-location-accuracy 1"

Also
pi@raspberrypi:~ $ sudo systemctl status dump1090-fa
Warning: The unit file, source configuration file or drop-ins of dump1090-fa.ser
● dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor pres
Drop-In: /etc/systemd/system/dump1090-fa.service.d
└─bias-t.conf
Active: activating (auto-restart) (Result: exit-code) since Tue 2020-12-08 12
Docs: https://flightaware.com/adsb/piaware/
Process: 3950 ExecStartPre=/home/pi/rtl_biast/build/src/rtl_biast -b 1 (code=e
Process: 3955 ExecStart=/usr/share/dump1090-fa/start-dump1090-fa --write-json
Main PID: 3955 (code=exited, status=1/FAILURE)
lines 1-10/10 (END)

hopefully this will tell you what I have to do

That’s not what is in the link for checking the log.

Trying again

ec 08 13:46:14 raspberrypi dump1090-fa[27265]: Found 1 device(s):

Dec 08 13:46:14 raspberrypi dump1090-fa[27265]: 0: Realtek, RTL2838UHIDIR, SN: 00000001

Dec 08 13:46:14 raspberrypi dump1090-fa[27265]: Using device 0: Generic RTL2832U OEM

Dec 08 13:46:14 raspberrypi dump1090-fa[27265]: Found Rafael Micro R820T tuner

Dec 08 13:46:17 raspberrypi systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).

Dec 08 13:46:17 raspberrypi dump1090-fa[27270]: /usr/share/dump1090-fa/start-dump1090-fa: 1: /etc/default/dump1090-fa: ««49.6: not found

Dec 08 13:46:17 raspberrypi dump1090-fa[27270]: /usr/share/dump1090-fa/start-dump1090-fa: 2: /etc/default/dump1090-fa: 40#: not found

Dec 08 13:46:17 raspberrypi dump1090-fa[27270]: Tue Dec 8 13:46:17 2020 GMT dump1090-fa 4.0 starting up.

Dec 08 13:46:17 raspberrypi dump1090-fa[27270]: rtlsdr: using device #0: Generic RTL2832U OEM (Realtek, RTL2838UHIDIR, SN 00000001)

Dec 08 13:46:18 raspberrypi dump1090-fa[27270]: Found Rafael Micro R820T tuner

Dec 08 13:46:18 raspberrypi dump1090-fa[27270]: rtlsdr: tuner gain set to 49.6 dB

Dec 08 13:46:18 raspberrypi dump1090-fa[27270]: Error opening the listening port 30104 (Beast TCP input): bind: Address already in use

Dec 08 13:46:18 raspberrypi systemd[1]: **dump1090-fa.service: Main process exited, code=exited, status=1/FAILURE**

Dec 08 13:46:18 raspberrypi systemd[1]: **dump1090-fa.service: Failed with result 'exit-code'.**

This shows that the port 30104 is already in use, probably you’ve set it up as outbound in VRS? It can prevent that dump1090-fa can be loaded

This is another problem. Did you probably mess up your dump1090 config file?

This is how start should look like:

dump1090-fa.service - dump1090 ADS-B receiver (FlightAware customization)
   Loaded: loaded (/lib/systemd/system/dump1090-fa.service; enabled; vendor preset: enabled)
   Active: active (running) since Sat 2020-12-05 14:31:00 CET; 3 days ago
     Docs: https://flightaware.com/adsb/piaware/
 Main PID: 1997 (dump1090-fa)
    Tasks: 3 (limit: 4915)
   CGroup: /system.slice/dump1090-fa.service
           └─1997 /usr/bin/dump1090-fa --device-index 0 --gain 49.6 --ppm 0 --max-range 360 --fix --net --net-heartbeat

Dec 05 14:31:00 WeeWX systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Dec 05 14:31:00 WeeWX dump1090-fa[1997]: Sat Dec  5 14:31:00 2020 CET  dump1090-fa 4.0 starting up.
Dec 05 14:31:00 WeeWX dump1090-fa[1997]: rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00001000)
Dec 05 14:31:00 WeeWX dump1090-fa[1997]: Detached kernel driver
Dec 05 14:31:00 WeeWX dump1090-fa[1997]: Found Rafael Micro R820T tuner
Dec 05 14:31:00 WeeWX dump1090-fa[1997]: rtlsdr: tuner gain set to 49.6 dB
Dec 05 14:31:01 WeeWX dump1090-fa[1997]: Allocating 4 zero-copy buffers

I assigned in VRS to port 8081

I have no idea if I messed up the config file. Just checked it. It is empty/does not exists.

is it possible to correct the port and the dump1090 config file?

the name of that folder is /etc/default, not /etc/dafault

oeps
Will try again.

««49.6
40# dump1090-fa configuration
# This is sourced by /usr/share/dump1090-fa/start-dump1090-fa as a
# shellscript fragment.

# If you are using a PiAware sdcard image, this config file is regenerated
# on boot based on the contents of piaware-config.txt; any changes made to this
# file will be lost.

# dump1090-fa won't automatically start unless ENABLED=yes
ENABLED=yes

RECEIVER_OPTIONS="--device-index 0 --gain 49.6  --ppm 0 --net-bo-port 30005"
DECODER_OPTIONS="--lat 52.509058 --lon 6.110759 --max-range 360 --fix"
NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 $
JSON_OPTIONS="--json-location-accuracy 1"



                               [ Read 16 lines ]

remove the first line completely and the 40 in front of # in second line. These are the previous errors due to misconfiguration.
The config file should start with

# dump1090-fa configuration

However that won’t fix the port issue.
For this specific topic it is required to know what is running on port 30104

Ok made the corrections

# dump1090-fa configuration

# This is sourced by /usr/share/dump1090-fa/start-dump1090-fa as a

# shellscript fragment.

# If you are using a PiAware sdcard image, this config file is regenerated

# on boot based on the contents of piaware-config.txt; any changes made to this

# file will be lost.

# dump1090-fa won't automatically start unless ENABLED=yes

ENABLED=yes

RECEIVER_OPTIONS="--device-index 0 --gain 49.6 --ppm 0 --net-bo-port 30005"

DECODER_OPTIONS="--lat 52.509058 --lon 6.110759 --max-range 360 --fix"

NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 $

JSON_OPTIONS="--json-location-accuracy 1"

so now the first two errors should disappear if you try starting dump1090-fa

Your port blocked issue should be still there.
It is required to verify what blocks that port. Can be an instance of VRS, MM2 or something else.

Please verify via sudo htop if any of these are still running in the background.

It is a very long file
pi@raspberrypi:~ $ pi@raspberrypi:~ $  sudo htop
-bash: pi@raspberrypi:~: command not found
pi@raspberrypi:~ $ 
pi@raspberrypi:~ $ 
pi@raspberrypi:~ $   1  [|||                                                                                            2.6%]   Tasks: 45, 56 thr; 1 running
-bash: syntax error near unexpected token `|'
pi@raspberrypi:~ $   2  [                                                                                               0.0%]   Load average: 0.42 0.26 0.15 
-bash: 2: command not found
pi@raspberrypi:~ $   3  [||                                                                                             1.3%]   Uptime: 02:42:40
-bash: 3: command not found
-bash: 1.3%]: command not found
pi@raspberrypi:~ $   4  [                                                                                               0.0%]
-bash: 4: command not found
pi@raspberrypi:~ $   Mem[||||||||||||||||||||||||||||||||||||                                                      114M/925M]
-bash: Mem[||||||||||||||||||||||||||||||||||||                                                      114M/925M]: No such file or directory
pi@raspberrypi:~ $   Swp[                                                                                          0K/100.0M]
-bash: Swp[                                                                                          0K/100.0M]: No such file or directory
pi@raspberrypi:~ $ 
pi@raspberrypi:~ $   PID USER      PRI  NI  VIRT   RES   SHR S CPU% MEM%   TIME+  Command
-bash: PID: command not found
pi@raspberrypi:~ $  8866 root       20   0  9340  4080  2300 R  2.6  0.4  0:07.30 htop
-bash: 8866: command not found
pi@raspberrypi:~ $   667 root       20   0  109M  7524  5476 S  1.3  0.8  1:39.95 /usr/bin/rbfeeder
-bash: 667: command not found
pi@raspberrypi:~ $   777 root       20   0 16436  9336  5468 S  0.0  1.0  0:17.87 /usr/bin/python3.7 /usr/bin/mlat-client --results beast,listen,30104 --input-type dump1090 --input-connect 127.0.0.1:32457 --server mlat1.rb24.com:40900 --
-bash: 777: command not found
pi@raspberrypi:~ $   829 root       -2   0  1936  1232  1084 S  0.0  0.1  0:02.70 /usr/sbin/watchdog
-bash: 829: command not found
pi@raspberrypi:~ $   776 root       20   0  109M  7524  5476 S  0.0  0.8  0:47.75 /usr/bin/rbfeeder
-bash: 776: command not found
pi@raspberrypi:~ $   814 piaware    20   0 25852 11568  6212 S  0.0  1.2  0:19.90 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json
-bash: 814: command not found
pi@raspberrypi:~ $   109 root       20   0 33208 15676 14720 S  0.0  1.7  0:17.42 /lib/systemd/systemd-journald
-bash: 109: command not found
pi@raspberrypi:~ $  3139 pi         20   0 12340  3432  2632 S  0.7  0.4  0:01.86 sshd: pi@pts/0
-bash: 3139: command not found
pi@raspberrypi:~ $   467 root       20   0 11144  3284  2656 S  0.0  0.3  0:08.55 wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext
-bash: 467: command not found
pi@raspberrypi:~ $   765 fr24       20   0  157M 14840  5792 S  0.0  1.6  0:07.73 /usr/bin/fr24feed
-bash: 765: command not found
pi@raspberrypi:~ $   721 root       20   0 70692  3224  2356 S  0.0  0.3  0:13.35 /usr/bin/pfclient -d -i /var/run/pfclient.pid -z /etc/pfclient-config.json -y /var/log/pfclient $
-bash: 721: command not found
pi@raspberrypi:~ $   738 root       20   0 70692  3224  2356 S  0.0  0.3  0:07.84 /usr/bin/pfclient -d -i /var/run/pfclient.pid -z /etc/pfclient-config.json -y /var/log/pfclient $
-bash: 738: command not found
pi@raspberrypi:~ $   688 root       20   0  124M 16176 11272 S  0.0  1.7  0:03.67 /usr/sbin/collectd
-bash: 688: command not found
pi@raspberrypi:~ $   817 root       20   0  124M 16176 11272 S  0.0  1.7  0:00.35 /usr/sbin/collectd
-bash: 817: command not found
pi@raspberrypi:~ $   803 www-data   20   0  9592  5644  3892 S  0.0  0.6  0:01.29 /usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
-bash: 803: command not found
pi@raspberrypi:~ $     1 root       20   0 32800  8292  6604 S  0.0  0.9  0:15.28 /sbin/init
-bash: 1: command not found
pi@raspberrypi:~ $  1080 tar1090    39  19  8016  1828  1472 S  0.0  0.2  0:06.09 /bin/bash /usr/local/share/tar1090/tar1090.sh /run/tar1090 /run/dump1090-fa
-bash: 1080: command not found
pi@raspberrypi:~ $   330 root       20   0 25512  2800  2488 S  0.0  0.3  0:02.99 /usr/sbin/rsyslogd -n -iNONE
-bash: 330: command not found
pi@raspberrypi:~ $   767 root       20   0  109M  7524  5476 S  0.0  0.8  0:03.56 /usr/bin/rbfeeder
-bash: 767: command not found
pi@raspberrypi:~ $   337 root       39  19  7808  2696  2512 S  0.7  0.3  0:02.43 /bin/bash /usr/share/graphs1090/service-graphs1090.sh
-bash: 337: command not found
pi@raspberrypi:~ $   365 avahi      20   0  5904  2512  2260 S  0.0  0.3  0:03.87 avahi-daemon: running [raspberrypi.local]
-bash: 365: command not found
pi@raspberrypi:~ $   349 messagebu  20   0  6548  3512  3020 S  0.0  0.4  0:04.29 /usr/bin/dbus-daemon --system --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
-bash: 349: command not found
pi@raspberrypi:~ $   844 fr24       20   0  157M 14840  5792 S  0.0  1.6  0:02.08 /usr/bin/fr24feed
-bash: 844: command not found
pi@raspberrypi:~ $   773 root       20   0  109M  7524  5476 S  0.0  0.8  0:00.30 /usr/bin/rbfeeder
-bash: 773: command not found
pi@raspberrypi:~ $   792 fr24       20   0  157M 14840  5792 S  0.0  1.6  0:01.20 /usr/bin/fr24feed
-bash: 792: command not found
pi@raspberrypi:~ $   771 root       20   0  109M  7524  5476 S  0.0  0.8  0:00.43 /usr/bin/rbfeeder
-bash: 771: command not found
pi@raspberrypi:~ $   849 piaware    20   0 25852 11568  6212 S  0.0  1.2  0:00.62 /usr/bin/piaware -p /run/piaware/piaware.pid -plainlog -statusfile /run/piaware/status.json
-bash: 849: command not found
pi@raspberrypi:~ $   845 fr24       20   0  157M 14840  5792 S  0.0  1.6  0:00.34 /usr/bin/fr24feed
-bash: 845: command not found
pi@raspberrypi:~ $   775 root       20   0  109M  7524  5476 S  0.0  0.8  0:00.31 /usr/bin/rbfeeder
-bash: 775: command not found
pi@raspberrypi:~ $   402 root       20   0 25512  2800  2488 S  0.0  0.3  0:01.53 /usr/sbin/rsyslogd -n -iNONE
-bash: 402: command not found
pi@raspberrypi:~ $   404 root       20   0 25512  2800  2488 S  0.0  0.3  0:01.41 /usr/sbin/rsyslogd -n -iNONE
-bash: 404: command not found
pi@raspberrypi:~ $   874 fr24       20   0  157M 14840  5792 S  0.0  1.6  0:00.94 /usr/bin/fr24feed
-bash: 874: command not found
pi@raspberrypi:~ $   768 root       20   0  109M  7524  5476 S  0.0  0.8  0:00.88 /usr/bin/rbfeeder
-bash: 768: command not found
pi@raspberrypi:~ $   774 root       20   0  109M  7524  5476 S  0.0  0.8  0:00.14 /usr/bin/rbfeeder
-bash: 774: command not found
pi@raspberrypi:~ $   734 root       20   0 70692  3224  2356 S  0.0  0.3  0:02.25 /usr/bin/pfclient -d -i /var/run/pfclient.pid -z /etc/pfclient-config.json -y /var/log/pfclient $
-bash: 734: command not found
pi@raspberrypi:~ $   769 root       20   0  109M  7524  5476 S  0.0  0.8  0:00.47 /usr/bin/rbfeeder
-bash: 769: command not found
pi@raspberrypi:~ $   143 root       20   0 18276  3928  3000 S  0.0  0.4  0:01.38 /lib/systemd/systemd-udevd
-bash: 143: command not found
pi@raspberrypi:~ $   327 systemd-t  20   0 22412  5632  4984 S  0.0  0.6  0:00.00 /lib/systemd/systemd-timesyncd
-bash: 327: command not found
pi@raspberrypi:~ $   288 systemd-t  20   0 22412  5632  4984 S  0.0  0.6  0:00.46 /lib/systemd/systemd-timesyncd
-bash: 288: command not found
pi@raspberrypi:~ $   329 nobody     20   0  4320  2024  1852 S  0.0  0.2  0:00.11 /usr/sbin/thd --triggers /etc/triggerhappy/triggers.d/ --socket /run/thd.socket --user nobody --deviceglob /dev/input/event*
-bash: 329: command not found
pi@raspberrypi:~ $   403 root       20   0 25512  2800  2488 S  0.0  0.3  0:00.00 /usr/sbin/rsyslogd -n -iNONE
-bash: 403: command not found
pi@raspberrypi:~ $   332 root       20   0  7976  2304  2124 S  0.0  0.2  0:00.05 /usr/sbin/cron -f
-bash: 332: command not found
pi@raspberrypi:~ $   338 root       39  19  3692   720   612 S  0.0  0.1  0:00.04 /usr/sbin/alsactl -E HOME=/run/alsa -s -n 19 -c rdaemon
-bash: 338: command not found
pi@raspberrypi:~ $   363 root       20   0 10740  3788  3416 S  0.0  0.4  0:00.14 /sbin/wpa_supplicant -u -s -O /run/wpa_supplicant
-bash: 363: command not found
pi@raspberrypi:~ $   367 root       20   0 13040  5952  5312 S  0.0  0.6  0:01.36 /lib/systemd/systemd-logind
-bash: 367: command not found
pi@raspberrypi:~ $   439 root       20   0 54652  8028  7060 S  0.0  0.8  0:00.00 /usr/sbin/ModemManager --filter-policy=strict
-bash: 439: command not found
pi@raspberrypi:~ $   455 root       20   0 54652  8028  7060 S  0.0  0.8  0:00.01 /usr/sbin/ModemManager --filter-policy=strict
-bash: 455: command not found
pi@raspberrypi:~ $   373 root       20   0 54652  8028  7060 S  0.0  0.8  0:00.28 /usr/sbin/ModemManager --filter-policy=strict
-bash: 373: command not found
pi@raspberrypi:~ $   381 root       20   0 27656    80     0 S  0.0  0.0  0:00.18 /usr/sbin/rngd -r /dev/hwrng
-bash: 381: command not found
pi@raspberrypi:~ $   382 root       20   0 27656    80     0 S  0.0  0.0  0:00.01 /usr/sbin/rngd -r /dev/hwrng
-bash: 382: command not found
pi@raspberrypi:~ $   383 root       20   0 27656    80     0 S  0.0  0.0  0:00.68 /usr/sbin/rngd -r /dev/hwrng
-bash: 383: command not found
pi@raspberrypi:~ $   380 root

So … reboot and show the dump1090-fa log again.

here it is:
# dump1090-fa configuration

# This is sourced by /usr/share/dump1090-fa/start-dump1090-fa as a

# shellscript fragment.

# If you are using a PiAware sdcard image, this config file is regenerated

# on boot based on the contents of piaware-config.txt; any changes made to this

# file will be lost.

# dump1090-fa won't automatically start unless ENABLED=yes

ENABLED=yes

RECEIVER_OPTIONS="--device-index 0 --gain 49.6 --ppm 0 --net-bo-port 30005"

DECODER_OPTIONS="--lat 52.509058 --lon 6.110759 --max-range 360 --fix"

NET_OPTIONS="--net --net-heartbeat 60 --net-ro-size 1300 --net-ro-interval 0.2 $

JSON_OPTIONS="--json-location-accuracy 1"

That’s not the log. …

@Dutchyb
No use breaking your head in debugging.
Purge the existing dump1090-fa, then reinstall dump1090-fa

The purge command not only removes the software, but also removes it’s configuration files, leaving distro clean and ready for fresh install.

sudo apt-get purge dump1090-fa  

sudo apt-get install dump1090-fa  

sudo reboot