FlightAware Discussions

Dual IP address

Hi, my system is getting better all the time.
From a basic RTL dongle using diy antenna to the full setup using Prostick+ and 1090 antenna, things are so much better, and having moved the antenna again as a last resort, the improvement is even better, but I’m at the limit of what I can capture due to my location and natural screening, but this is not my problem?

Ive just noticed that my PiAware 3.8.1 setup using RP4 is now displaying two IP addresses, showing this setup connected to Wireless & LAN.
I’d prefer to use LAN and have been doing so to-date, and when I plug in the ethernet cable, wireless would disable, reported on screen, however not the case just now.
I managed to enter the config.txt file on the MSDC and removed my SSD user and password, yet it still shows two IP addresses when I restart the system, and I have also rebooted the router.

I know next to nothing when it comes to editing software, but have returned the config.txt too as it was before, in the hope that someone here can explain in simple speak, what is wrong if at all it is wrong?

So, Used to cut off when LAN connected, now it has dual IP address and wireless stays on with LAN connected!

Thankyou

Nothing is wrong.

There are two network interfaces and if you enter the following

route

You get output that looks like

pi@Pi6:~ $ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         fritz.box       0.0.0.0         UG    202    0        0 eth0
default         fritz.box       0.0.0.0         UG    303    0        0 wlan0
192.168.178.0   0.0.0.0         255.255.255.0   U     202    0        0 eth0
192.168.178.0   0.0.0.0         255.255.255.0   U     303    0        0 wlan0
pi@Pi6:~ $

The column marked Metric shows the order in which the network interfaces will be used with a lower number indicating a higher priority.

In this case the eth0 (cabled) network interface has a Metric of 202 and wlan0 (WiFi interface) has a Metric of 303.

The network traffic will use the lan0 interface by default and switch to the wlan0 interface if the eth0 fails.

S

Thank you for that.

I’ll attach my mouse and keyboard later and try to take a look. Using Linux is all very new to me.

I’ll assume then, that I’ve missed this point earlier on since setup, but certain that Wireless would show as ‘down’ when LAN was in use.

You should activate SSH so you don’t need the keyboard.
I’m also using a RPI4 and in the piaware-config.txt file I have the following:
rfkill yes
wireless-network no
If I’m not wrong, “rfkill yes”, will put RPI4 in airplane mode, turning off wifi and bluetooth, “wireless-network no” will disable wireless network (probably irrelevant because it’s in airplane mode).
I’m also expecting the rfkill will also lower the RPI4 power needs.

Thank you.

I did set wireless to ‘no’, even removed password and user name but it still displayed both IP addresses.

I’m completely alien to Linux, Raspberry, PiAware, but all this information is helping more than you realise.

I’m enjoying the Pi4 setup with its ‘little’ ice tower compared to my heavy lumbering old PC setup, but need to learn more about the software and programming.

Did you reboot? Because otherwise that file isn’t checked i believe.

There is a bug in the currently released version where where if you had a valid wireless config in the past, then later change to wireless=no, the originally generated wireless configuration files will not be removed so the old config will persist.

Try removing /etc/wpa_supplicant/wpa_supplicant.conf and rebooting:

sudo rm /etc/wpa_supplicant/wpa_supplicant.conf

(be careful with that command, sudo rm can do a lot of damage if pointed at the wrong place…)

That said, unless you have particular reasons to want to disable wifi, it’s mostly harmless to have both wifi and wired interfaces up at the same time - as mentioned above they have different metrics, so the wired interface will be used in preference if both are available.

Yes indeed, I have experienced this when I just started to learn Linux and issued command sudo rm -rf /* :slightly_smiling_face:.

Linux is very powerful, but this power can easily break things if not used carefully.

That’s a little bit like cleaning the car interior with that:

1 Like

While I was an officer in the USAF around 1991, we had a young airman working on Sun 3 computer with UNIX. He had read the books and knew everything, just like we all did when we started working with computers. Anyway, he was running out of disk space as his logs were getting full, and figured he could use abcd567’s command above to clean up a few files. And as you already know, he figured out it was not a good command to use, and then had to learn how to fully install the operating system from scratch. Good learning experience. I spoke with an old UNIX guru and he laughed about this happening to all new people. This was designed into UNIX from the beginning. The initial developer knew people would try to see if they could mess up the system, so he made it easy. Peer pressure from others affected by the trashed system forced the new people to learn from the experience. I think he was insightful. And yes, I did this to one of my own systems too. I have always learned much more about how things work by doing making stupid mistakes and then having to fix the same.

I shut down my Pi4, remove the memory card and edit the config.txt file on my MacBook, save the edit then eject the sd card.

I’ll assume that’s akin to rebooting.

Great, having really changed nothing my end, I was hoping someone would say something similar that there’s an issue with an update!

Thank you everyone for your input so far. I’m gonna get me another micro sd card, install the full Raspberry software, and proper read the manual, so I’ve got a better understanding of what I can and shouldn’t do with Linux.

:rofl: :rofl: :rofl:

 

1 Like