Displaced center marker in map (dump1090-mutab)


#1

I have been running dump1090-mutability on an original Raspberry Pi B for a couple of weeks now, feeding to several tracking aggregators simultaneously.
I must say I an very impressed and satisfied with how everything works. Initially I installed dump1090-mutability in Raspbian Wheezy which worked fine enough when running on its own. But when I tried to install the PiAware feeder on top of that, it was no longer possible to establish a reliable wifi connection. So I switched to Raspbian Jessie and then used Joe Prochazka’s excellent script to instead install FR24, PlaneFinder and ADS-B Exchange, and everything is now running smoothly.

Anyway, I recently noticed that the center marker for the position of my antenna is rendered offset towards south by approximately 375 meters on the local map (***<my.IP>/dump1090/gmap.html***). I am not sure when that started, but I don’t remember having seen it before. I do know, however, that both coordinate values set in the /etc/default/dump1090-mutability config file are still correct and valid. The map layer I use is the default OpenStreetMaps. It appears that the marker can’t be nudged to a correct position even by setting an appropriatly compensated “fake” value on purpose. Nothing happens when adjusting the less significant decimals. But when changing the third digit to < 5 or >= 5. respectively the marker responds in very large increments.

To clarify: A latitude degree is about 111.12km long, therefore 1°/1000 (0.001°) corresponds to about 111m. Now, my exact latitude position happens to be 59.463366 degrees North, but the position rendered is approximately at 59.460000 (according to Google Earth). That’s a displacement of 0.003366 degree or 375 m. Tentatively changing the input value to 59.466 to compensate just makes the point jump north circa 1,12 km! Note that the latter distance is only 1% more than the length of 1°/100, which seems suspiciously significant.

I am a little confused about this, and I guess there may be multiple-choice explanations: Is this lack of resolution when setting the receivers’s coordinates by design, as it were? Or is it because of a minor bug in either OpenStreetMaps or dump1090? Or is it simply a matter of misconfiguration on my part?

I haven’t found anything about this particular behaviour in the forum, but maybe someone here is able to shed some light.


#2

Take a look in
/usr/share/dump1090-mutability/html/config.js

You will need to restart lighttpd after the change then refresh your browser.


#3

Okay, thanks.
I will try that tomorrow. It’s getting late here…

// Martin


#4

This will be the JSON_LOCATION_ACCURACY setting in the dump1090-mutability config. It defaults to rounding your receiver location somewhat. If you’re happy with giving out an exact position to anyone with access to your map, set it to “exact”.


#5

@ obj
Super! Just what I was looking for. Thank you.