Did the Lan Timer check and Watchdog and offline


#1

I had a few hangups so going through the messages here I added the wlan0 check and the watchdog timer check. Now I cannot get into the pi at all and it seems to be offline as its not connected to my network. I pulled the power and let it reset and its still offline. The wlan0 check I did was the lan reboot not the full reboot

Im getting ready to head out to the Seahawks game so Ill have to check later, but other than spelling (which Im sure I double checked) is there anything else I need to do or has anyone done this and had the same problem ?


#2

connected monitor and keyboard and had to log into lan again. Made sure I saved the lan settings hopefully it will hold.

I have a video resolution issue but Ill find a raspberry forum to figure that out.


#3

Dang it, offline again.

I gotta get into it and take that lan check out. Its not working right.


#4

This may or may not help. Here are my WiFi configs:

/etc/network/interfaces


auto lo

iface lo inet loopback
iface eth0 inet dhcp

# For Direct Ethernet Connection
#address 192.168.1.5
#netmask 255.255.255.0
#network 192.168.1.0
#broadcast 192.168.1.255
#gateway 192.168.1.1



auto wlan0
allow-hotplug wlan0
iface wlan0 inet static
wpa-scan-ssid 1
wpa-ap-scan 1
wpa-key-mgmt WPA-PSK
wpa-proto RSN WPA
wpa-pairwise CCMP TKIP
wpa-group CCMP TKIP
wpa-ssid "-------SSID FOR YOUR WIFI NETWORK--------"
wpa-psk "------NETWORK PASSWORD THAT HAS BEEN RUN THROUGH MD5-------"
address 192.168.1.4
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1

#wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

/root/network_monitor.sh


#!/bin/bash

while true ; do
   if ifconfig wlan0 | grep -q "inet addr:" ; then
      sleep 60
   else
      echo "Network connection down! Attempting reconnection."
      ifup --force wlan0
      sleep 10
   fi
done


#5

Did you make sure to include the ampersand (&) when you added the line to /etc/rc.local?


/root/network_monitor.sh &

Go Hawks!


#6

Just got home and couldnt ssh in so I put it on a hardware line till I get it fixed :slight_smile:

Voice is gone and Im cold to the bone but it was worth it.


#7

w7psk:

I have had experiences with two RasPIs that would go off line on wireless simply due to the power supply. I was using a good spec’d 5VDC supply that was well suited. The RasPIs would run for a day (or maybe a few days) then go off wireless. I monkey’ed around with WiFi settings, etc forever. I kept reading posts in the RasPI forum suggesting a power supply issue but I thought, “can’t be my problem because my power supply is awesome, etc.”

Turns out… It was my power supply. :blush: Something about quick transients in power locking the WiFi but not causing a reboot or other issues. I would certainly suspect your power supply as part of the debug process.


#8

EDIT:
I was wrong, they bought the one that has the .3amp power supply. Ill be ordering the 2.5A one ASAP