FlightAware Discussions

Data not getting through to servers?

Hi all.

Getting lots of problems of late with some data not getting through to the servers my PI is connected by Wi-Fi and I’m on 100mb internet with Virgin Media in the UK the PI is in a bedroom where Wi-Fi is picked up fine by mobiles so not sure why I keep getting this?

686

I’m quite handy with linux and networks, and it was only by chance that i found out what the problem is.
For me it was the router using a tunnel to bundle wired internet and mobile internet.
That reorderd the packet i believe creating the problem.

Anyway if MLAT is still working and maybe even if not, this kind of thing is really hard to debug.
So it’s probably not worth the effort.

The lowest effort would likely be, trying an ethernet cable to exclude the WiFi connection as a cause.
Or just turn the RPi on it’s side or the other side.
See if that helps with WiFi reception.
The RPi3 has a very bad antenna.

1 Like

All I have is one of those BT Wi-Fi extenders similar to the below

I’ve tried to connect the PI to that before via the Ethernet port but never had any success

You have to use ‘raspi-config’ to configure that.

sudo raspi-config

Using the piaware-config options seems like the better approach on a piaware-image.

Could I just not go into the file remove the wifi details then get one of these https://www.argos.co.uk/product/1070754 and connect it up without having to do any other configuration? Would it just automatically pick up the connection?

If piaware-config has wired network enabled then yes.

But i’m not sure it’s worth it.

If you didn’t have problems before it’s much more likely that the problem is temporary and not going to be solved by Ethernet.
(using ethernet only makes sense temporarily to exclude WiFi, can’t you relocate it with a cheap indoor antenna and set in the same room as the router? doesn’t even need an ethernet cable, WiFi at that short distance shouldn’t be a problem and exclude the wifi reception in the other room as cause of the problems)

In my experience, if you have a lot of WiFi routers around you, in the 2.4GHz band, you will have lost packets. There are only like 3 usable channels by default in those routers: 1, 6 and 11.
I have directly wired my Pi (Ethernet) and solved similar issues.

Unless a new neighbor just moved in with a high-powered router on the other side of his wall.

Had another look through Argos and I decided to try the TP-LINK 600MBPS Nano Powerline https://www.argos.co.uk/product/5742734

It works an absolute treat constant connection off 100mpbs and the issues seem to have gone away

Didn’t even have to change any settings on the SD card just plugged the Ethernet and in instantly connected

1 Like