Daddy-son project round 2- connecting to home wifi


#1

Now my son is in bed. I’m trying to connect the thing to home wi-fi instead of my mobile hotspot so I can stop using my mobile hotspot, and have it be working by the morning. I have moved the entire apparatus to the same desk that has the wi-fi router.

I tried both 2.4GHz and 5GHz with WPA2-PSK security setting, but I can’t connect to the wi-fi. It keeps saying “Wireless network: wlan0 down.” Very much appreciate any lead to solving the problem.


#2

Are you running “sudo raspi-config”?


#3

One possibly is that the WI-FI is in fact connecting but you are not getting an IP address allocated from your home network’s DHCP server (assuming you haven’t configured a static IP address). Have you tried rebooting your router?


#4

Tried that but didn’t work. How else can I troubleshoot?


#5

wlan0 down means that it’s not even managing to associate with your AP; it hasn’t got as far as trying DHCP yet.

You’ll probably need to ssh in and have a poke around in the logs to work out what’s going wrong.


#6

@SoNic67: I just mounted the default program from the website onto the microSD card and the only thing I changed was the wifi name and password. How do I go about following your suggestion?

@obj: when you say “ssh” do you mean “Alt +F10” option that I get in the beginning which allows me to see the system log?


#7

Without WiFI he can’t SSH in. He is using a monitor/keyboard connected to the Pi.

@luminlee
Just type in the keyboard “sudo raspi-config” and hit enter.
I gave you the link for how to above:

SSH is a way to connect to the Pi from another PC, using a software (I am using PuTTY). It’s easier to “work” because you can copy/paste things from the Internet in that window. But your Pi needs to be setup first with that command.


#8

can you connect via ethernet instead? (at least that way you’ll be up and running and you can learn all about linux and the wifi while piaware is running and you and your son are enjoying) PS, have aspirin ready re the linux stuff


#9

Not only that, if he did not create an empty ssh.txt in the root directory of the SD card, it won’t work even with a functional WiFi.


#10

With the raspi-config you don’t need anything, it has a section to setup SSH.
You guys don’t do that raspi-config the first time you boot? If nothing, at least to extent the partition space to fill the whole SD card!


#11

When using the FA image, all I do after the ‘burn’, with the card still in the PC is: enter SSID, WiFi password, Feeder-ID in piaware-config. Then create an SSH.TXT in the root directory of the card.

From then on, PuTTY is your friend.


#12

You can have wired ethernet and wifi simultaneously enabled.

Current piaware (and standard raspbian) images do this automatically on first boot.


#13

ssh is a service that runs on the Pi that will let you connect to a command-line shell on the Pi from another machine. You can use clients like ‘putty’ on Windows. It might be easier than hooking up a keyboard/monitor since you can cut+paste on your regular PC and so on.

Actually working with the shell and poking at the logs is, uh, a large topic. You’ve got a tricky one here because usually, wifi should “just work” - working out why it’s not working can rapidly get very technical.

The obvious thing to check to start with is that you have the SSID and passphrase set exactly correctly in piaware-config.txt. They are case sensitive. Do you have any unusual characters in the SSID or passphrase?


#14

Wow thank you very much for everyone’s input.

Happy to report that it is working with the ethernet cable!

Will need a bit of time to learn at the same time! So much depth for what originally was a simple father-son project!


#15

Enjoy the time together! Because sooner or later a girl will steal him away :wink:


#16

If it’s your router i would suggest temporarily changing the wifi name and password to something well not too complicated like lower case letters and maybe some numbers.
Just to eliminate that as a problem.

Also in the local shell you may type following commands after logging in with ALT-F2

sudo -s
wpa_cli (this puts you in a program to control wifi stuff)
interface wlan0

Now you should wait and see the authentication fail or whatever else goes wrong.
you can also type:
scan (wait a bit)
scan_results

to see if the pi sees the wifi of your router.

quit to quit application and exit to leave the login (twice as sudo -s logs you in as root on top of the other session) and i guess the pi will return to the status screen.

also (not in wpa_cli application) you could try:
cat /etc/wpa_supplicant/wpa_supplicant.conf

to see if the name and passwords got transferred correctly (not sure why it wouldn’t be but hey)


#17

glad this worked for you (the ethernet). remember, the most simple solution is usually best. hope both you and your son enjoy this project. like you, i am new to this and find that i can deal with hardware (filters, attenuators, low noise amps etc) much better than linux solutions. i will say that the folks on this forum are great, as are the staff at flightaware…all care and are happy to help.


#18

Now is the best time to use sudo raspi-config It’s easiest way to finish setting up the Pi - for beginners.


#19

Is raspi-config really needed with piaware?


#20

No, but AFAIK it’s included in every distribution of Debian on Raspberry Pi. It’s a very simple interface for beginners to use to setup WiFi, SSH, etc…