FlightAware Discussions

Changed USB Dongle. No data on PiAware Skyview

#1

Hello.
I have changed my USB Dongle with Flightaware Pro Stick Plus and Flightaware antenna.
I have powered off Raspberry Pi, changed usb dongle with the new one, powered on but had no data on PiAware Skyview with Flightaware Pro Stick Plus USB Dongle.
Do i have to register as a new site? Why do I have no data?
Swithced again on old USB Dongle. Worked fine.

Any advice?
Thank you.

#2

Can you try the new dongle with the old cable/antenna?

Also after starting it please use this command to show the relevant log and share it here:

sudo journalctl -u dump1090-fa -n50 --no-pager
1 Like
#3

I would try installing the new one in a different USB port for start, see if it makes a difference.

#4

Doesn’t the new dongle have a new serial ID, thus you need to re-claim it?

#5

No the unique feeder id is generated when piaware starts feeding for the first time.

If you use a new sd-card or delete the piaware configuration then you need to claim the station again or configure your old feeder id.

1 Like
#6

It was on different usb port. I forgot to mention it.

#7

I will try and keep you posted. I cannot use the old antenna. I have a sma connector on the new Flightaware Pro Stick Plus.

#8

The logs will be most useful, can you connect to the pi with putty or ssh?

@abcd567
Do you have a putty / ssh guide for piaware sd-cards lying around or what you usually link?

#9

Then move it to the same port and reboot. Sometimes it takes a couple of reboots to settle the device index back to the default 0.

Because I was playing with multiple dongles too, I found useful to use the rtl_sdr package to see what happens or to change the serial numbers (if needed).

sudo apt-get update
sudo apt-get install rtl-sdr

usage: rtl_sdr (investigation) or rtl_eeprom (changing serial number)

1 Like
#10

How-to SSH to RPi - Setup Putty in Windows

#11

pi@piaware:~ sudo journalctl -u dump1090-fa -n50 --no-pager -- Logs begin at Tue 2019-01-08 16:35:28 UTC, end at Tue 2019-01-08 16:37:24 UTC . -- Jan 08 16:35:36 piaware systemd[1]: Starting dump1090 ADS-B receiver (FlightAwar e customization)... Jan 08 16:35:36 piaware systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization). Jan 08 16:35:36 piaware dump1090-fa[529]: Tue Jan 8 16:35:36 2019 UTC dump1090 -fa 3.6.3~bpo8+1 starting up. Jan 08 16:35:37 piaware dump1090-fa[529]: rtlsdr: using device #0: Generic RTL28 32U (Realtek, RTL2832U, SN 00001000) Jan 08 16:35:37 piaware dump1090-fa[529]: Found Rafael Micro R820T tuner Jan 08 16:35:37 piaware dump1090-fa[529]: rtlsdr: tuner gain set to 49.6 dB pi@piaware:~

#12

still no data with The Pro Stick

#13

I wonder if the gain is too high for you. Right now it seems to be on AGC.

#14

The log looks fine which probably means the dongle is working.

You can check if the cabling has a pin where it is needed (dongle has no pin, cable needs a pin) and at the connection to the antenna you should check if the pin is the right size to fit the antenna (there have been cases where the pin was too small).

If you want to check the dongle to make sure it is working you can disconnect the cable and put in around 7cm of wire. It will serve as an antenna (not too good but better than a faulty cable).
The wire needs to be relatively thin to fit.

That could reduce the number of planes but it is unlikely it would result in absolutely no data.

You can also use the following commands to check if dump1090-fa itself is receiving something:

view1090-fa --no-interactive
view1090-fa

If it is receiving anything you should instantly see results.

#15

Thanks.
Still no data:
http://green-tech.ddns.net:8080
What I cannot understand is why with pro stick and antenna from flightaware I have no data and with ordinary one I do. Beats me…

#16

I’m going to change to my old dongle again…

#17

It might indeed be as Sonic suggested.

Try reducing the gain with

sudo piaware-config rtlsdr-gain 38
sudo systemctl restart dump1090-fa

I just checked http://green-tech.ddns.net:8080/data/stats.json
which shows a very high signal that is always present.

It could also be that with the new antenna electrical noise is stronger than the ADS-B messages because a source of electrical noise is located close to the antenna.

#18

I’ve done as you said. Still no data: green-tech.ddns.net:8080

#19

Most likely electrical noise is the problem.

Can you try moving the antenna or is it already on the roof?

#20