Can't upgrade to 3.6.2


#1

Somehow I’ve managed to get my rPi into a state where the current flightaware install 3.5.3, won’t upgrade to 3.6.2. Here is what happens when I try it:

pi@piaware:~ sudo dpkg -i piaware-repository_3.6.2_all.deb (Reading database ... 25285 files and directories currently installed.) Preparing to unpack piaware-repository_3.6.2_all.deb ... Unpacking piaware-repository (3.6.2) over (3.6.2) ... Setting up piaware-repository (3.6.2) ... pi@piaware:~ sudo apt-get install piaware
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
piaware : Depends: libreadline7 (>= 7.0~beta) but it is not installable
Depends: libssl1.1 (>= 1.1.0) but it is not installable
piaware-release : Depends: piaware-repository (= 3.6.2~bpo8+1) but 3.6.2 is to be installed
Depends: piaware-support (= 3.6.2~bpo8+1) but 3.5.3 is to be installed
Depends: piaware (= 3.6.2~bpo8+1) but 3.6.2 is to be installed
Depends: beast-splitter (= 3.6.1~bpo8+1) but 3.5.0 is to be installed
Depends: dump1090-fa (= 3.6.2~bpo8+1) but 3.5.3 is to be installed
Depends: piaware-web (= 3.6.1~bpo8+1) but 3.5.0 is to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).
pi@piaware:~$

Trying the suggestion of apt-get -f install produces this result:

pi@piaware:~$ sudo apt-get -f install
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following packages were automatically installed and are no longer required:
atmel-firmware beast-splitter crda dump1090-fa firmware-atheros
firmware-brcm80211 firmware-intelwimax firmware-iwlwifi firmware-libertas
firmware-ralink firmware-realtek firmware-ti-connectivity firmware-zd1211
fontconfig ifplugd itcl3 iw libbladerf-udev libbladerf1
libboost-program-options1.55.0 libboost-regex1.55.0 libboost-system1.55.0
libdatrie1 libdrm2 libertas-firmware libfam0 libgraphite2-3 libharfbuzz0b
libiw30 libnl-3-200 libnl-genl-3-200 libpango-1.0-0 libpangocairo-1.0-0
libpangoft2-1.0-0 libplymouth4 librtlsdr0 libtcl8.6 libthai-data libthai0
lighttpd mime-support nano netcat-openbsd piaware piaware-support
piaware-web plymouth plymouth-themes rfkill rtl-sdr socat tcl tcl-tls tcl8.6
tcllib tclx8.4 usbutils wireless-regdb wireless-tools wpasupplicant
Use ‘apt-get autoremove’ to remove them.
The following packages will be REMOVED:
piaware-release
0 upgraded, 0 newly installed, 1 to remove and 58 not upgraded.
2 not fully installed or removed.
E: Can’t find a source to download version ‘3.5.3’ of ‘piaware:armhf’

I’m fairly new to the whole unix & flightaware stuff so I’m at a loss as to what is missing or how to resolve it. My system is working well on 3.5.3 so its not a pressing issue. I’d just like to keep up with the current version.


#2

This is the stretch repository package; it’s not going to work with a 3.5.3 Jessie sdcard image.
Also, to upgrade a sdcard image, it’s the piaware-release package that’s critical, not the piaware package.

At this point I suggest you just reimage with the 3.6.2 image (or actually, wait a couple of days for 3.6.3 to come out and use that), it’ll probably work out simpler. If you want to try the more complex route of trying to repair your existing image, try this (YMMV):

wget http://flightaware.com/adsb/piaware/files/packages/pool/piaware/p/piaware-support/piaware-repository_3.6.2~bpo8+1_all.deb 
sudo dpkg -i piaware-repository_3.6.2~bpo8+1_all.deb
sudo apt-get update && sudo apt-get install piaware-release

More generally, to upgrade a 3.5.3 install, I’d suggest either using the “upgrade” command from the stats page, or “apt-get update && apt-get upgrade” from the command line. There is no need to re-install the repository package.


#3

Thanks. I’ll wait a bit for the latest version and then re-image the sd card. Once I do that, will FlightAware still recognize my installation as an existing one or do I need to re-register?


#4

After reinstalling, run piaware-config feeder-id <UUID here> using the long “unique identifier” UUID shown on the stats page of your old site.