FlightAware Discussions

Can see aircraft on map but not showing any stats on site

Hi,

I have a raspberry pi 4 and flightaware pro plus. I can see aircraft on my map (but distance is blank), however my stats in my account are blank.

in the setting page I can see in the log section “30005, not starting multilateration client yet
[2020-12-18 16:28 GMT] no ADS-B data program is serving on port 30005, not starting multilateration client yet”

Any help is much appreciated!

Make sure to set your lat and lon location.

Lat and lon both showing in the site info section. Ive checked it in edit location and " I would like to pick my receiver’s location on a map."

What image did you start with?

Started with a new image using the official raspberry pi imager, it installed the new Rasperry Pi OS that was released earlier this month, would have preferred to install Raspbian but it wasn’t an option. I installed flight aware as per the instructions on the site. All seemed to go smoothly other than this issue.

So check that the dump1090-fa service is running:
https://github.com/wiedehopf/adsb-wiki/wiki/Debug-commands#dump1090-fa

Also do a reboot for good measure.

Raspberry Pi OS and Raspbian are the same thing, they just renamed it.
I’m not sure if the standalone install will take the location from the location configured on the stats page but it should.

For some extras like graphs (in case this gets you working) you can check here: https://github.com/wiedehopf/adsb-wiki/wiki/Raspbian-Lite:-ADS-B-receiver

That must be an old log bit … or it just needed the reboot.

This is the output :

– Logs begin at Wed 2020-12-16 07:17:01 GMT, end at Fri 2020-12-18 17:29:46 GMT. –
Dec 16 07:22:48 pi-flight systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Dec 16 07:22:49 pi-flight dump1090-fa[470]: Wed Dec 16 07:22:49 2020 GMT dump1090-fa 4.0 starting up.
Dec 16 07:22:49 pi-flight dump1090-fa[470]: rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00001000)
Dec 16 07:22:49 pi-flight dump1090-fa[470]: Detached kernel driver
Dec 16 07:22:49 pi-flight dump1090-fa[470]: Found Rafael Micro R820T tuner
Dec 16 07:22:49 pi-flight dump1090-fa[470]: rtlsdr: enabling tuner AGC
Dec 16 07:22:49 pi-flight dump1090-fa[470]: Allocating 4 zero-copy buffers
Dec 18 16:09:26 pi-flight systemd[1]: Stopping dump1090 ADS-B receiver (FlightAware customization)…
Dec 18 16:09:26 pi-flight dump1090-fa[470]: Fri Dec 18 16:09:26 2020 GMT Caught SIGTERM, shutting down…
Dec 18 16:09:27 pi-flight dump1090-fa[470]: Fri Dec 18 16:09:27 2020 GMT Waiting for receive thread termination
Dec 18 16:09:27 pi-flight dump1090-fa[470]: Reattached kernel driver
Dec 18 16:09:27 pi-flight dump1090-fa[470]: Fri Dec 18 16:09:27 2020 GMT Normal exit.
Dec 18 16:09:27 pi-flight systemd[1]: dump1090-fa.service: Succeeded.
Dec 18 16:09:27 pi-flight systemd[1]: Stopped dump1090 ADS-B receiver (FlightAware customization).
Dec 18 16:09:27 pi-flight systemd[1]: Started dump1090 ADS-B receiver (FlightAware customization).
Dec 18 16:09:27 pi-flight dump1090-fa[24567]: Fri Dec 18 16:09:27 2020 GMT dump1090-fa 4.0 starting up.
Dec 18 16:09:27 pi-flight dump1090-fa[24567]: rtlsdr: using device #0: Generic RTL2832U (Realtek, RTL2832U, SN 00001000)
Dec 18 16:09:27 pi-flight dump1090-fa[24567]: Detached kernel driver
Dec 18 16:09:28 pi-flight dump1090-fa[24567]: Found Rafael Micro R820T tuner
Dec 18 16:09:28 pi-flight dump1090-fa[24567]: rtlsdr: enabling tuner AGC
Dec 18 16:09:28 pi-flight dump1090-fa[24567]: Allocating 4 zero-copy buffers

Make sure site position and range rings is set. Click the setting gear at the top of the SkyAware map.

I’ve selected site position and range rings but they are not showing on the map.

Well you have multiple stations … not sure which one the current install is claimed as.
https://flightaware.com/adsb/piaware/claim

Or maybe it’s not yet claimed.

Are you sure that you have set up the device properly and claimed it using the FA instructions that it is registered in your account?

Or did you use a previously used feeder ID?

Yes, it should. At least i can confirm it from my last installations.

Site 142960 does not have a location specified. Location is estimated by FA.

It looks like it has created two site numbers for the one site. 1426960 and 1426961.

then you need to set up one correctly including location
and use the feeder ID on your device

The other will be removed automatically after some days. Or you can do it by yourself manually after 24 hours

Thank you everyone. Much appreciated.