FlightAware Discussions

Anyone working with the new x86 Raspbian


#41

Well most likely they are all 64bit operating systems. Hmm maybe Raspberry Pi desktop is as well.

Not sure what they did :stuck_out_tongue_winking_eye:
(i googled around a bit and i’m still not sure, it might use a 64bit kernel if the hardware supports it, the applications are all 32 bit. this can introduce additional errors and might be quite a bit less tested.)


#42

Couldn’t see between the lines, Did Oliver have any tips for you? Any ideas for next steps? My hardware is similar to yours: 32/64 bit but with quad core, 775 socket processor. If I get my WiFi running I can try it on my machine ruling out hardware specific issues. Are we running a 64 bit Raspbian or is it 32 bit?


#43

Old but reliable advice. Start with simple compile. Move to more complex. Isolate the compile failure in dmp1090 by isolating compileable subsets and building up. I’ve been around lots of compiler problems and isolating a particular issue isn’t pretty. What language is dmp1090? Tcl? Is it interpretive or compile?


#44

No idea.
My knowledge of compilers & compilation is nearly zero. I learned C and C++ in mid 1990s as hobby, then never used it. Due to this disuse, I forgot all I have learnt.

Oliver (@obj) can guide you


#45

Okay, reviewed the error. You are using gcc to compile dmp1090. The bus error is a general one usually related to hardware issues. That doesn’t seem to be the case here since your h/w is working fine. If i get my WiFi working (ie load correct driver as per my recent post), then I can dup your efforts and eliminate h/w issue. This post looks promising:

“ I was having issues with my wireless, too; I have no idea how or why, but after entering the command:

sudo apt-get install --reinstall bcmwl-kernel-source


and rebooting,  `gcc`  started working again. I'm confident that this did the trick, as I tried compiling just before issuing the command.

While I'd still like to understand why that happened, I guess this fixed the problem.

#46

I recall that at the time when I was learning C & C++, I used a compiler named rhide. It was on a 3.5" floppy disket


#47

I recall lot’s more older stuff than that. However, the post I gave you was about the bus error from gcc. Might work. Do you know how to load a new Linux driver on the Raspbian we are running? If I get my WiFi working, we can solve the compiler problem. I have lots of resources to call on. Oliver was one (unless he just happened to be peaking in on the thread.)


#48

.
I am not at home now, will try your command when back home.

.
.

.
No, I dont know this.


#49

You sound like you are doing fine. Linux great when you get the hang.

Many years ago I did a wee bit of assembler but out of the loop with programming now, can do a few scripts, that is about all.

Geffers


#50

Before you do that do you mind checking the kernel version Raspbian Desktop is using?

uname -a

this command should do :slight_smile:

gcc -v

would also be interesting.
(I’m mainly curious, probably won’t help fix your error.)

Does Raspbian in the bootmanager allow booting another kernel, maybe a 32bit one if it is running a 64bit right now?

Most likely my top recommendation to both of you would be using another distribution.
Go with Ubuntu 18.10 or Debian unstable.


#51
pi@raspberrypi:~ $ uname -a
Linux raspberrypi 4.9.0-8-amd64 #1 SMP Debian 4.9.130-2 (2018-10-27) x86_64 GNU/Linux


pi@raspberrypi:~ $ gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/i686-linux-gnu/6/lto-wrapper
Target: i686-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Debian 6.3.0-18+deb9u1' --with-bugurl=file:///usr/share/doc/gcc-6/README.Bugs --enable-languages=c,ada,c++,java,go,d,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-6 --program-prefix=i686-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-libmpx --enable-plugin --enable-default-pie --with-system-zlib --disable-browser-plugin --enable-java-awt=gtk --enable-gtk-cairo --with-java-home=/usr/lib/jvm/java-1.5.0-gcj-6-i386/jre --enable-java-home --with-jvm-root-dir=/usr/lib/jvm/java-1.5.0-gcj-6-i386 --with-jvm-jar-dir=/usr/lib/jvm-exports/java-1.5.0-gcj-6-i386 --with-arch-directory=i386 --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --with-target-system-zlib --enable-objc-gc=auto --enable-targets=all --enable-multiarch --with-arch-32=i686 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-checking=release --build=i686-linux-gnu --host=i686-linux-gnu --target=i686-linux-gnu
Thread model: posix
gcc version 6.3.0 20170516 (Debian 6.3.0-18+deb9u1) 
pi@raspberrypi:~ $ 

#52

.

pi@raspberrypi:~ $ sudo apt-get install --reinstall bcmwl-kernel-source
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package bcmwl-kernel-source
pi@raspberrypi:~ $ 

#53

@obj
@wiedehopf
@billbresl

I installed this distro in Oracle VM, and could easily compile dump1090-fa. No compiler problem.

In both cases, the machine is same and the distro is same.
The only difference is that in USB Flash, it is a Live CD with Persistence, while in Oracle VM it is NOT a live CD, it is a regular installation on Hard Drive.

EDIT: I feel we should try this:

  • Burn the Live CD .iso to a DVD
  • Boot from DVD, and choose option “install”
  • Plug a USB Flash to PC and choose USB Flash as Hard Drive on which Live CD should install the distro
  • Complete installation process.
  • Remove Live CD, and boot from USB Flash.

#54

Super info. Oliver, any hints, tips, or tricks?


#55

[ S O L V E D]

@obj
@wiedehopf
@billbresl

.

Just now tried my above suggestion. SUCCESS :smile:

.

2018-12-21-102415_657x422_scrot

Since LInux has drives designated as sda1, sda2, … etc, which are very similar, I was afraid that by mistake I may choose the hard drive which has Windows. This mistake would have replaced Windows by Raspbian. :angry:

To avoid this disaster, I first shutdown the computer, opened its cover, and disconnected wires from my Hard Drive.

Only after that I booted from Live CD with a blank USB Flash plugged-in. Now there was no chance to install Raspbian on Windows Hard Drive as it was electrically disconnected :smile:

After finishing installation of Raspbian x86 on USB Flash, I shutdown computer, re-plugged the Hard Drives wires, and restarted computer. Chose boot from USB Flash, and installed dump1090-fa as per steps I have posted at GitHub: https://github.com/jprochazka/adsb-receiver/issues/473

.


#56

I’m pretty sure it would already be installed but you can try this:

sudo apt-get update
sudo apt-get install firmware-linux-nonfree

Have you restarted after plugging in the USB dongle? It should not be required but i won’t hurt either :slight_smile:

To be honest i would just use something that is not based on Debian stable, that is basically always outdated. (I think i said that before ;))


#57

@billbresl

If you have burned the .iso directly to the USB Flash then you are running “Live CD with Persistance”.

I have now discovered that using Live CD directly gave me the problem of compilation.
When I installed the distro on USB Flash (treating it as a Hard Drive), the problem was solved. May be your WiFi problem is also due to direct use of Live CD.

By the way, have you set the “WiFI Country” in Raspi Configuration? Without this setting, WiFi wont work.

Applications Menu (click on raspberry at top-left corner) >> Preferences >> Localisation >> Set WiFI Country.
Please see screenshot below

Click on image to see larger size
Click again to see full size


#58

Congrats! Well done! Regarding my WiFi, will try to follow your suggestions after lunch appt. Did try 3 different Wi-Fi dongles from various generations. Did verify RaspBian sees the USB devices: my 8 gig boot stick for Raspbian and my Linksys WiFi dongle. Hoping it’s a fast lunch!


#59

My Raspbian x86 was not seeing any WiFi interface and nor any WiFi routers. The list was blank, till I set the WiFi country, and after that suddenly there was my WiFi dongle listed, and all my neighbours and my own WiFi showed up in the list. :smile:


#60

Country is set. Used a bash command to look at ‘devices.’ Output showed the two usb devices and what was attached to them. The driver list supported is large. However, my 2010 era dongles aren’t in the list. My new 2.5/5.0 dongle is not in the list. I have the driver for it on usb but it’s on a win file system. Any hints on how to put Linux driver on usb memory and then load it into the raspbian desktop. I can look it up but any tips are appreciated.

New windows 10 build is available in you are Windows Insider. Build will preview the new sandbox feature which will help us do all this Raspbian stuff in windows own virtual world rather than your Oracle stuff. I’ve always been on the front edge of Win dev and former MS partner for many, many years.