FlightAware Discussions

Anyone working with the new x86 Raspbian


#21

Will be first adventure with Github. Looking forward to my tomorrow.


#22

The only interaction/adventure with GitHub is that you will download the script’s package from GitHub by issueing the command git clone https://github.com/jprochazka/adsb-receiver.git.

Once the script’s package is downloaded, everthing is local to your computer. GitHub is no more involved.


#23

Reading github tutorial now and looking for git. And watching Rockets. Thx for the baby steps since I need them. Watching folks do cool stuff is not near as satisfying as doing stuff. Update tomorrow. One thing if you have brain cells left. My pc WiFi dongle did not come up Raspbian so I’m off the net. It is pretty new 2.4/5.0 device and I’m thinking I need a driver. Is that a reasonalbe guess? Is finding/installing a driver on Raspbian doable?


#24

Did you enable / choose WiFi interface? Click on the WiFi / network icon at top right of screen to open settings dialouge. Try both the right click and left click.


#25

Raspbian doesn’t see my WiFi devices. I have two really old ones and one new one. It tells me there are no Wi-Fi devices connected. Thoughts? Is there a list of the WiFi devices supported by this release? My pi with it’s built in WiFi works perfectly, of course.


#26

@obj
@wiedehopf
ANY THOUGHTS?

The workaround I posted at GitHub worked OK at that time.

Issue #473: Workaround to build .deb package of dump1090-fa 3.6.3 Without bladeRF, on armhf & amd64

.

Today I applied that workaround to Raspbian X86, then tried to build dump1090-fa

FAILED - This is the result:

2018-12-20-105659_681x482_scrot

.

Full output

pi@raspberrypi:~ $ cd dump1090
pi@raspberrypi:~/dump1090 $ sudo dpkg-buildpackage -b
dpkg-buildpackage: info: source package dump1090-fa
dpkg-buildpackage: info: source version 3.6.3
dpkg-buildpackage: info: source distribution stable
dpkg-buildpackage: info: source changed by Oliver Jowett <oliver@mutability.co.uk>
dpkg-buildpackage: info: host architecture i386
 dpkg-source --before-build dump1090
 debian/rules clean
dh clean --with=systemd
   dh_testdir
   dh_auto_clean
	make -j1 clean
make[1]: Entering directory '/home/pi/dump1090'
rm -f *.o compat/clock_gettime/*.o compat/clock_nanosleep/*.o dump1090 view1090 faup1090 cprtests crctests convert_benchmark
make[1]: Leaving directory '/home/pi/dump1090'
   dh_clean
	rm -f debian/debhelper-build-stamp
	rm -f debian/dump1090.substvars
	rm -f debian/dump1090.*.debhelper
	rm -rf debian/dump1090/
	rm -f debian/dump1090-fa.substvars
	rm -f debian/dump1090-fa.*.debhelper
	rm -rf debian/dump1090-fa/
	rm -rf debian/.debhelper/
	rm -f debian/*.debhelper.log
	rm -f debian/files
	find .  \( \( \
		\( -path .\*/.git -o -path .\*/.svn -o -path .\*/.bzr -o -path .\*/.hg -o -path .\*/CVS \) -prune -o -type f -a \
	        \( -name '#*#' -o -name '.*~' -o -name '*~' -o -name DEADJOE \
		 -o -name '*.orig' -o -name '*.rej' -o -name '*.bak' \
		 -o -name '.*.orig' -o -name .*.rej -o -name '.SUMS' \
		 -o -name TAGS -o \( -path '*/.deps/*' -a -name '*.P' \) \
		\) -exec rm -f {} + \) -o \
		\( -type d -a -name autom4te.cache -prune -exec rm -rf {} + \) \)
	rm -f *-stamp
 debian/rules build
dh build --with=systemd
   dh_testdir
   dh_update_autotools_config
   dh_auto_configure
   debian/rules override_dh_auto_build
make[1]: Entering directory '/home/pi/dump1090'
dh_auto_build -- RTLSDR=yes BLADERF=no DUMP1090_VERSION=3.6.3
	make -j1 RTLSDR=yes BLADERF=no DUMP1090_VERSION=3.6.3
make[2]: Entering directory '/home/pi/dump1090'
cc -Wdate-time -D_FORTIFY_SOURCE=2 -DMODES_DUMP1090_VERSION=\"3.6.3\" -DMODES_DUMP1090_VARIANT=\"dump1090-fa\" -DENABLE_RTLSDR -g -O2 -fdebug-prefix-map=/home/pi/dump1090=. -fstack-protector-strong -Wformat -Werror=format-security -std=c11 -O2 -g -Wall -Werror -W -D_DEFAULT_SOURCE -I/usr/include/ -c dump1090.c -o dump1090.o
cc1: internal compiler error: Bus error
cc: internal compiler error: Bus error (program cc1)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-6/README.Bugs> for instructions.
Makefile:41: recipe for target 'dump1090.o' failed
make[2]: *** [dump1090.o] Error 4
make[2]: Leaving directory '/home/pi/dump1090'
dh_auto_build: make -j1 RTLSDR=yes BLADERF=no DUMP1090_VERSION=3.6.3 returned exit code 2
debian/rules:23: recipe for target 'override_dh_auto_build' failed
make[1]: *** [override_dh_auto_build] Error 2
make[1]: Leaving directory '/home/pi/dump1090'
debian/rules:32: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2


#27

Asking for some help from good friend on this. Here are the list of some Linux drivers that support my most current WiFi dongle. Do you know if any of these drivers are included in the x86 distribution?


#28

Oops. Here’s the list: https://rehmann.co/blog/drivers-wifi-usb-adapter-osxmac-linux-windows/


#29

Tried to install dump1090-mutability ver 1.15~dev on Raspbian X86 - FAILED

@obj
@wiedehopf

Any thoughts?

.

2018-12-20-115736_655x480_scrot


#30

Compiler (or compiler build) bug


#31

Thanks Oliver for prompt reply.
How to solve compiler bug?


#32

Tried again after following command, problem persists:

sudo apt-get install --reinstall binutils

.

Tried again after this command, problem persists.

sudo apt-get install --reinstall gcc

sudo apt-get install --reinstall build-essential

.

2018-12-20-123256_660x454_scrot


#33

What computer are you running it on?

Could be a problem with running 32bit software on 64bit hardware.


#34

I would advise you to use another distribution. This is based on debian stable which won’t have the best hardware support.

Something like debian unstable (doesn’t mean it doesn’t run stable it just means it is much more current) would probably work.

Or Ubuntu 18.10.


#35

I’m not sure it’s necessary but do a reboot after plugging them in. Maybe that will work.


#36
pi@raspberrypi:~/dump1090 $ cat /proc/cpuinfo
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
stepping	: 10
microcode	: 0xa0b
cpu MHz		: 2667.000
cache size	: 6144 KB
physical id	: 0
siblings	: 2
core id		: 0
cpu cores	: 2
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm kaiser tpr_shadow vnmi flexpriority dtherm
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips	: 5999.37
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 23
model name	: Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz
stepping	: 10
microcode	: 0xa0b
cpu MHz		: 2667.000
cache size	: 6144 KB
physical id	: 0
siblings	: 2
core id		: 1
cpu cores	: 2
apicid		: 1
initial apicid	: 1
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx lm constant_tsc arch_perfmon pebs bts rep_good nopl aperfmperf pni dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm sse4_1 xsave lahf_lm kaiser tpr_shadow vnmi flexpriority dtherm
bugs		: cpu_meltdown spectre_v1 spectre_v2 spec_store_bypass l1tf
bogomips	: 5999.37
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:


#37

Does compiling other stuff work?
As a shot in the dark you could remove the stackprotector from the compiler options.


#38

.

Tried only following, both gave identical error (compiler)

  • dump1090-fa 3.6.3
  • dump1090-mutability ver1.15~dev

.

How to do that? My knowledge of compilation and compilers is almost zero :slight_smile:


#39

Hmm i thought it would be in the makefile but it is not :confused:

Try adding

-fno-stack-protector

In the CFLAGS line in the file Makefile

Probably won’t help.

My guess: memory is somehow mapped wrong or the bios is doing something strange.
Using a 64bit distribution will probably alleviate the problem.

Maybe you can limit RAM in the bios to 4Gig or something?


#40

.

My Desktop’s ram is 8Gb.

Never faced any problem when running WinXP, Win8, and Ubuntu18 (All 3 on Hard Drive, Can choose which one to run at boot time).

I will tomorrow try to install latest Raspbian Stretch X86 rpd on Oracle VM on Win8 on this Desktop, and try to compile dump1090-fa from source code.