FlightAware Discussions

Announcing PiAware 5!

I probably do. I did not do anything with the feeder besides updating it and have no idea how the 978 started.
I started feeding just for fun ( to drink beer and see aircrafts on screen)
Now the thing is useless and I think that its better to dispose that equipment all together.
I also tried to suspend the 978 with no sucess :frowning:

systemctl mask --now dump978-fa

Sorry if that sounded ill tempered … wasn’t meant as such.

Is it the piaware image yes?

That is ironically counter productive unless you also reboot the pi.

Without rebooting:

sudo piaware-config uat-receiver-type none
sudo systemctl unmask dump978-fa
sudo systemctl disable --now dump978-fa

That should get you back to the beer drinking asap, cheers! :slight_smile:

In case you want to also look at some more fancy statistics: GitHub - wiedehopf/graphs1090: Graphs for dump1090 (based on dump1090-tools by mutability)
This can also be a nice visualization of traffic in your area: GitHub - wiedehopf/tar1090: Provides an improved webinterface for use with ADS-B decoders readsb / dump1090-fa

But those last things were off topic so if you have questions about those … i’ll suggest to open a new thread.

1 Like

Thanks very much for the update to PiAware and dump1090-fa although as usual I’m filled with fear and trepidation at the thought of updating a prefectly working system and breaking something although the lure of having the latest & greatest is exerting a very strong pull! :crazy_face:

Thanks also for SkyAware Anywhere a great addition to the family which is working well for me and saves me having to VPN in when I am away from home. :+1:

As usual I have more questions than ever after having read through all 202 posts in this thread and so will try and break it down to make it easier to receive help from you guys who know these things! :blush:

It appears I can update PiAware & dump1090-fa from the FlightAware web interface by clicking on the Settings cog and updating them one at a time from the dropdown.

Having just run sudo apt update I can see that both can alternatively be updated by sudo apt full-upgrade also.

Is there a preference for one or the other bearing on mind my Pi wasn’t created from the PiAware image? :confused:

Just a reminder that I initially setup my Pi4 as a RadarBox feeder, then added FR24 and finally FA thanks to the help given here and on other forums and would really like to add ADSBExchange to continue my policy of giving back to those sites I take from.

I did join ADSBx the other day but it wouldn’t let me post because it thought it was Spam despite my deleting the couple of lines that I thought might be responsible. It was good to see a couple of familiar names on there so I know I will be capable hands when I finally figure out how to post! :rofl:

I also have a nicely working Graphs setup and have read instances where that stops working after updating although it seems it can be fixed by installing Tar1090 which I don’t have but would like to try.

Does Tar1090 work separately from the existing Graphs package as an addition or does it replace the Graphs package entirely? I wouldn’t want to lose the 3 months or so of history I have accumulated so far.

Would there be a preferred order in which to upgrade PiAware and dump1090-fa to v5 and install Tar1090 and ADSBExchange I wonder? :thinking:

Thanks & kind regards,
-=Glyn=-

It is really something quite different to graphs1090 and the fact that it may fix something is just because it employs AI cough, no seriously now has a bunch of stupid hard-coded logic to fix up some of the more common lighttpd (webserver) issues on the pi.

Just update piaware/dump1090-fa first and install tar1090 afterwards if you want to try it, graphs1090 will be fine. (the graphs1090 page describes ways to backup the data as well)
This is kinda off topic so if you have further questions … open a separate thread please.

Thanks for the quick reply as always weidehopf!

Understood and will do. :+1:

So was there any preference for me to just issue the sudo apt update followed by sudo apt full-upgrade to update all of the packages on my Pi including both piaware/dump1090-fa or via the FA website/Settings/Device Commands/Upgrade & restart PiAware followed by Upgrade & restart dump1090? :thinking:

Am hoping that the former would be best as that is what I always use to keep things up to date but would update independently via the website if that might turn out to be easier/safer/better. :grin:

Thanks & kind regards,
-=Glyn=-

Thank you for trying to help out. Sadly that was not working either. I reinstalled completely new SD card image and still I don´t get any feed. Now it shows my location correctly and also displays skyaware 5.0 but I think that tere is still some conflict with the BiasTee. I followed the instructions here: Radio for Everyone: PiAware with rtl-sdr blog v.3 and ADS-B preamp installation for bias-T
And the last command was a failure. I did not get the same response like instructions suggested but some strange dongle.

pi@piaware:~/rtl_biast/build $ cd src && sudo service dump1090-fa stop && ./rtl_biast -b 1 && sudo service dump1090-fa start Found 1 device(s): 0: Realtek, RTL2838UHIDIR, SN: 00000001 Using device 0: Generic RTL2832U OEM Kernel driver is active, or device is claimed by second instance of librtlsdr. In the first case, please either detach or blacklist the kernel module (dvb_usb_rtl28xxu), or enable automatic detaching at compile time. usb_claim_interface error -6

I´m very close to donating the equipment to someone who can actually use it :woozy_face:

I have actually written a script for the bias tee stuff:
RTL Bias Tee · wiedehopf/adsb-wiki Wiki · GitHub

2 Likes

What exactly have you installed?
Have you installed any other feeders such as FR24?
The error message still says that the dongle is in use.

I installed PiAware 5 No FR24 was installed

I’m too slow, the script works like a charm!

For me, i had to blacklist first, then run those commands to enable the bias-t.

echo -e ‘blacklist rtl2832\nblacklist dvb_usb_rtl28xxu\nblacklist rtl8192cu\nblacklist rtl8xxxu\n’ | sudo tee /etc/modprobe.d/blacklist-rtl-sdr2.conf

And add the step to have it start on reboot automatically. Would assume this is all covered in wiedehopf’s script.

1 Like

After running your script the thing started to magically work !
What was the issue is unclear for me but it is back
Beers on me :beers:
Thank you.

2 Likes

 

Following were missing:

-DDETACH_KERNEL_DRIVER=ON (in cmake command)

ExecStartPre=/usr/bin/rtl_biast -b 1 (in file dump1090-fa.service)

 

1 Like

Well I decided to update the Pi running PiAware, FR24 & RBFeeder today and all seemed to go well up until the part where it said;

Configuration file ‘/etc/default/dump1090-fa’
==> Modified (by you or by a script) since installation
==> Package distributor has shipped an updated version
What would you like to do about it ? Your options are:
Y or I : install the package maintainer’s version
N or 0 : keep your currently-installed version
D : show the difference between the versions
Z : start a shell to examine the situation
The default action is is to keep your current version.
*** dump1090-fa (Y/I/N/O/D/Z) [default=N] ?

So given the choice I thought I’d hit D to show me the difference between the versions just to check before I ploughed ahead regardless as I do remember inputting my lat/lon and possibly gain at some point.

The lines that followed seemed to indicate these differences so wishing to proceed I noticed a block of reverse highlighted text at the bottom that said lines 1-17/17 (END) but then I couldn’t escape from this no matter what I tried.

I hit Y/I/N/O/D/Z CTRL-C/CTRL-X & RETURN and a combination of these but it didn’t want to move on at all.

I haven’t seen anyone mention this so assume its only happened to me - born lucky I guess :crazy_face: so what did I miss?

I ended up using SSH to power off the Pi and swapped the current microSD Card with a backup/cloned card I took just before attempting the update using SD Card Copier from the Accessories menu on the Pi desktop using Microsoft Remote Desktop which is what I use as my Pi’s are in the loft hanging on the end of PoE cables.

I’m going to try again but wondering what I missed here as I cloned 3 microSD Cards just prior to attempting the upgrade as a belts & braces approach…but when I am prompted next time I guess I’ll just select N to continue as it seems the default action is to retain the original.

Thanks & kind regards,
-=Glyn=-

I’ve seen this on all of my installations. I ignored it and always selected “No, i want to keep my version”.

None of them ran into issues so far

Plucked up the courage to try the update again and all was well this time. :smiley:

Like you I selected N and it went through and worked its magic and all seems to be working well and the webpage shows I am indeed now running PiAware 5. :+1:

There was a warning on the webpage telling me my CPU was at 100% and maybe I should consider getting a Pi2 which was a little bit odd as I am using a Pi4/4GB and showing 7% CPU locally so I gave it a few minutes and the warning disappeared.

Big thank you to the devs for a smooth upgrade…much appreciated! :beer:

I even threw caution to the wind and installed tar1090 and that seems to be working perfectly as well. Big thanks again weidehopf. :+1:

In fact so confident was I that I even edited the Range Rings line to show them at 50, 100, 150, 200 & 250 to match my other map views. :smiley:

You know after cloning onto a spare microSD Card just in case… :crazy_face:

Kind regards,
-=Glyn=-

It’s the less pager (remember “more”? Less is more…). Hit q to exit.

2 Likes

obj…at my age I can’t even remember how old I am! :rofl:

-=Glyn=-