Announcing PiAware 3! (Latest version: 3.8.0)

You can doubleclick on the table entry or the aircraft icon itself but we do seem to have lost the ability to do it from the info window, I’ll see about getting that fixed.

Cool. Those options work for me.

Coming from 3.1.0, you used to be able to set “ChartBundleLayers = true” in the config.js file to get a couple other layers. This setting appears to no longer work. I only have the 5 options under “overlay toggles”

Has this been removed or relocated to a different spot?

I feel I should know this, but I do not.

3.5 is showing B-787s with 4 engine, “747 like icon.” Is there an EZ fix, and if so, how? Thank you.

Curious about what happened to “day of upgrade” data … My Tuesday (4/4) data just “went away” after having been posted before.
3.5.0 seems to perform better than the previous version I installed a couple weeks ago.

Please read this thread about stats: ads-b-flight-tracking-f21/what-s-up-with-ads-b-statistics-t38873.html

Question from a Noob-

So, if I shut down my PiAware unit, format the SD card, and install a new image, and turn it back on, does this mean all my statistical data, site number, and “broadcasting since” data will all be wiped out?

Your current site is identified by hardware MAC address so if you are still running on the same hardware, you don’t need to do anything special to continue using your existing site.

Anyone using piaware 3.5 checked ChartBundle maps today?
I just reloaded a fresh load of 3.5 and made the customizations I normally do for my network etc. I then edited config.js file for Bing maps. extra range rings, and ChartBundle. Everything works fine except I am getting blank base layer when I select any aviation map.
Do I need to dig more, does it not work with 3.5, or is the map server down???

EDIT: Guess it was server all is normal now

since this morning, i have not column “distance” on Skyview list :frowning: and i have “unknown version” :question: also in skyview, but on my page it is indicated Feeder Type: PiAware (SD Card) 3.5.0

Have everybody this problem, what can i do to see Distance?
i reboot pi but same problem
Station LFMC


Try clearing your browser cache.

Small bug in the stylesheet for v3.5.0, the font-family is defined as Helvetica Neue only with no backup through a large portion of the doc, the initial entry is OK.

I noticed that the table used a Serif font and work (Windows) and a Sans Serif (Mac) font at home so I went digging.

The stylesheet initially defines the font-family as Helvetica Neue, Sans-Serif; but then only as Helvetica Neue later on. My Mac at home has this font family installed, my PC at work doesn’t.

If you add Sans-Serif to all the families using Helvetica it all looks fine.

Here is a sample of the code below:

font-family: Helvetica Neue;
font-size: 14px;
line-height: 18px;
color: #002F5D;
color: rgb(0, 47, 93);

font-family: Helvetica Neue;
font-size: 14px;
line-height: 18px;
color: #000000;
color: rgb(0, 0, 0);

font-family: Helvetica Neue;
width: 100%;
font-size: 12px;
color: #000000;
color: rgb(0, 0, 0);
display: inline-flex;
justify-content: flex-end;
padding-top: 10px;

Yeah, this is being fixed for the next release.

Is it normal with the 3.5.0 release for helicopters to not have tracks like winged aircraft do in PiAware Skyview?

I had helicopter tracks in 3.3.0 and that went away when I upgraded to 3.5.0.

If it’s a bug or unintended, I request a fix in the next version.

I have helicopter tracks fine on mine in 3.5.0 at the moment, sounds like something is not quite right there.

Going to need more details on this (screenshots as a starting point; details on your install)

Maybe posting about my issue fixed it in a weird way. I know the typical responses to issues with piaware displays are clear browser cache or relaunch browser and I do that with Firefox every day. I didn’t do that today (yet) but when I brought up my browser for the day and waited for a lifeguard or sheriff’s helicopter to show up in order for me to make my screen shots for this reply, a lifeguard helicopter showed up and the tracks actually worked. A sheriff’s helicopter later in the afternoon also has working tracks. These are the first instances of helicopter tracks working for me since the upgrade to 3.5.0. I’ve never had an issue with plane (winged aircraft) tracks and 3.5.0 running piaware on a raspberry pi.

Glad that it’s working now.

If it happens again please collect a good bug report. I don’t know what you’re seeing at all so I need to know basic things like: is it that you are getting no positions at all for helicopters? Or are they showing a position, but there is no historical track when you select them? Or are they showing with the wrong icon i.e. not a rotorcraft icon? Or are you not hearing them at all, not even as Mode S contacts? What is an example of an aircraft address & time when you had problems? Are the helicopters ADS-B equipped or are you relying on mlat for positions?

Simplest way to cover a lot of that is with screenshots.

Having a problem trying to install the upgrade 3.5.0 from my 3.3.0 system.
I entered the following: It is telling me I have UMET dependencies on 3.3.0 when trying to install 3.5.0 ??
What am I missing here ?

pi@piaware:~$ sudo apt-get update
Hit jessie InRelease
Get:1 jessie InRelease [22.9 kB]
Get:2 jessie InRelease [12.2 kB]
Hit jessie/piaware armhf Packages
Get:3 jessie/main armhf Packages [9,530 kB]
Get:4 jessie/main armhf Packages [156 kB]
Get:5 jessie/ui armhf Packages [57.9 kB]
Ign jessie/piaware Translation-en_US
Ign jessie/piaware Translation-en
Ign jessie/main Translation-en_US
Ign jessie/main Translation-en
Ign jessie/ui Translation-en_US
Ign jessie/ui Translation-en
Get:6 jessie/contrib armhf Packages [43.2 kB]
Get:7 jessie/non-free armhf Packages [84.2 kB ]
Get:8 jessie/firmware armhf Packages [1,232 B ]
Ign jessie/contrib Translation-en_US
Ign jessie/contrib Translation-en
Ign jessie/firmware Translation-en_US
Ign jessie/firmware Translation-en
Ign jessie/main Translation-en_US
Ign jessie/main Translation-en
Ign jessie/non-free Translation-en_US
Ign jessie/non-free Translation-en
Fetched 9,908 kB in 23s (419 kB/s)
Reading package lists… Done
pi@piaware:~$ sudo apt-get install piaware
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
piaware-release : Depends: piaware-repository (= 3.3.0) but 3.5.0 is to be inst alled
Depends: piaware (= 3.3.0) but 3.5.0 is to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a s olution).

That is a sdcard install. do one of:

$ sudo apt-get dist-upgrade


$ sudo apt-get install piaware-release

The second command is what the “upgrade piaware” remote command does on a sdcard install.

piaware-release is a metapackage used on sdcard installs that has dependencies on all the necessary packages.