FlightAware Discussions

Announcing PiAware 3! (Latest version: 3.7.1)

#865

sudo systemctl restart piaware is not working ?

#866

Strange I also tried to reinstall the dump1090-fa again
and the sudo apt-get upgrade it seems to be starting now :slight_smile:

well not sure what happened but is working again.

Thanks anyway :wink:

#867

What hardware and sdcard image are you using?
Have you disabled IPv6?

#868

I think I installed it manually on rpi a long time ago on jessie and then upgraded to stretch.
Anyway it seems to be working again, the solution seeme to be to reinstall dump1090-fa

And then again a sudo apt-get update / upgrade + reboot

#869

neither of those files are there. Here is the 2 directories

pi@piaware:/etc/kernel/postinst.d
$ ls
apt-auto-removal initramfs-tools rpi-bootconfig zz-update-bootconfig

pi@piaware:/etc/kernel/postrm.d
$ ls
initramfs-tools rpi-bootconfig zz-update-bootconfig

#870

I tried it for a few days and I found it too hard to quickly find the information I needed to compare signals between different setups.

Up till the last update I could click on a plane and see everything that I needed in the popup. With 3.6.3 it is hidden in the new table and I have to scroll up and down reading the table looking for the one or two bits of information.

I have reverted the two systems I upgraded back to 3.6.2 and will wait for something easier to work with.

I am unsure what problem was solved by taking the information out of the popup and hiding it three screen scrolls away.

S.

1 Like
#871

Probably adding the RSSI info to the hover is the way to go. I support that.

1 Like
#872

On Sept 16th, I upgraded PiAware from v3.5.3 to v3.6.2 and at the same time upgraded my Pi from Pixel to Stretch. I wonder if some algorithms counting the number of positions were changed because the migration is clearly visible on my stats page especially when looking at the ‘ads-b’ and ‘other’ crossover and the mlat drop?

#873

It looks like you maybe changed your gain setting to me?

You lost position count basically < 100 nmi.

So my assumption would be you had a fixed gain set, something like 40 and now it’s probably on -10 (automatic gain control).

#874

Nope, the first thing I did after the reinstall was entering my feeder ID and put rtlsdr-gain back at 42.
I also have ModeSmixer2 running and my reception range has not changed, it’s roughly a circle still crossing London, Amsterdam, Frankfurt and Paris.

#875

Compare the 17th and the 10th in the coverage graph on your stats page.

It’s clear you are getting quite a few less positions close in than before that’s why i’m asking.

How did you perform the install of the new version?
(If you did it via apt-get install it may be that you need to set gain in /etc/default/dump1090-fa instead of the piaware settings)
Also i believe you need to restart dump1090-fa after changing the gain setting via piaware-config.
(sudo systemctl restart dump1090-fa or just cycle the power)

#876

I just upgraded and I like the way the info is laid out.

#877

I decided to do a clean install from scratch because I wanted to upgrade from Pixel to Stretch.
I always keep a spare Pi at hand so I’m thinking about preparing a Piaware 3.5.3 with my feeder ID so I can swap back to the old version just to check if my positions go up to the same level as before. Unfortunately I cannot just swap the sd-card because the Pi’s are not identical (v3B vs v3B+)

#878

@alleyoopie Did you do a restart after changing the gain?
(sorry to be insistent but that’s the only explanation i can think of for loosing the close in position count while the far positions stay the same)

Just can’t think of any reason for the problem.
Maybe the pi you are now using is having some kind of problem (unlikely)?
Anyway good luck with fixing it :slight_smile:

#879

I always do a systemctl restart piaware each time when playing with the gain.
I remember there was a way to see with which parameters dump1090-fa is running but I forgot the correct syntax…

#880

one method is cat /etc/default/dump1090-fa

#881

try
journalctl | grep gain

to check the gain setting.

I’m not sure dump1090 is restarted with piaware as i’m not too familiar with the sd-card image install.
But on the sd-card install the /etc/default file is ignored as far as i know.

#882

Well, if i do a piaware-config, one of the parameters says rtlsdr-gain 42
If I do a cat /etc/default/dump1090-fa I get --gain -10 !!

#883

so this is the working gain ! don’t know why but if alter gain manually in the piaware-config.txt file and then service piaware restart nothing changes…

ED1 maybe should be set properly via piaware-config gain=nn then restart the service.

#884

@evangelyul @alleyoopie

I don’t have an sd-card install but i believe you need to restart dump1090-fa not piaware after changing the gain.

sudo systemctl restart dump1090-fa

should do the trick nicely.