FlightAware Discussions

Announcing PiAware 3! (Latest version: 3.7.1)


Why the Raspbian doesn’t default the /boot image to 100MB? The SD cards now are so much bigger, you can’t even find a 2GB anymore!


I dunno. The default that upstream pi-gen uses is twice the used space after the image has been prepared. For 3.6.3 I increased that to twice the used space + 64MB (and also got rid of the stray initramfs thing that was unexpectedly making an initramfs get built on upgrade)

1 Like

I noticed initram.fs appear on pi with every kernel upgrade
with 3.6.2 upgrade same thing, no space etc result everything upgraded BUT the kernel…
so this time followed different route.
after apt-get update I run rpi-update which upgraded to current 4.14.70 v7+
I rebooted.
confirmed ok with uname -a
and then apt-get dist-upgrade. the piaware update still tries to upgrade the kerlel
(maybe that should be left out of piaware normal upgrades) but fails (on paper !) after upgrading to 3.6.3 . so 3.6.3 works, kernel works regardless of what initram.fs say.

as for the boot partition best is 512Mb fat32. ED1 as I find USB stick more reliable than SD cards.
my 2c


It is. Normal piaware upgrades upgrade only piaware, not the whole system.
(specifically, they’ll do either an apt-get install piaware or apt-get install piaware-release for package-based and sdcard installs respectively)

They don’t do a full system upgrade for exactly the reasons you’re finding, there can be unexpected fallout that needs a human to diagnose.


then is apt responsible for the kernel upgrade ?


sudo rpi-update should do a kernel upgrade.


apt will also upgrade the kernel on the new raspbian. i believe before stretch it was only managed via rpi-update.


I noticed that too.
sudo apt-get update
sudo apt-get dist-upgrade
Should do it via apt-get. (edited)


not quite.

apt-get update (that’s the same as before)

apt-get dist-upgrade (does even major version jumps, stable -> testing for example but only if you have the testing packet sources)

apt-get upgrade (only does non-major upgrades which are less likely to break stuff.)


I upgraded both the following using Win32DiskImager :slight_smile:

  • Piaware SD card img
  • Stretch img + package install

Getting error on upgrade as not enough room, did a file check?
Any suggestions?

df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 7.3G 1.3G 5.7G 18% /
devtmpfs 460M 0 460M 0% /dev
tmpfs 464M 0 464M 0% /dev/shm
tmpfs 464M 18M 447M 4% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
/dev/mmcblk0p1 43M 33M 11M 76% /boot
tmpfs 93M 0 93M 0% /run/user/1000

Here is the error

pi@piaware:~ $ sudo apt-get dist-upgrade
Reading package lists… Done
Building dependency tree
Reading state information… Done
Calculating upgrade… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Setting up initramfs-tools (0.130) …
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.130) …
ln: failed to create hard link ‘/boot/initrd.img-4.14.69+.dpkg-bak’ => ‘/boot/initrd.img-4.14.69+’: Operation not permitted
update-initramfs: Generating /boot/initrd.img-4.14.69+

gzip: stdout: No space left on device
E: mkinitramfs failure cpio 141 gzip 1
update-initramfs: failed for /boot/initrd.img-4.14.69+ with 1.
dpkg: error processing package initramfs-tools (–configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)


Upgrade using Etcher / Win32DiskImager. You will get no errors at all. :slight_smile: :wink:


I have talked about that a few posts above, read the whole thread:

Ended up re-imagining. Etcher. Re-installing everything and finding on web all my adjustment took a while tough. @ evangelyul gave a suggestion to upgrade the kernel before everything, but it came too late for me.
Oliver promised that the next updates will work “in place”. Will see :slight_smile:


Then I have to reinstall modesmixer again and a couple other programs I have on there.



That’s the PITA with RPi add-ons. I gave up on them some time ago. It’s ‘plain vanilla’ Piaware for me.

I do my other stuff from the Windows PC.


Another option would be to use

to resize the partitions on the sd card. (May take some time to resize)
Be sure to only work on the sd-card not on your own hard drive.
A backup is recommended if you value something on the sdcard.

Or if you are already running linux somewhere you can just install and use gparted.


That is what I also do, but I made it a bit easier by writing all steps and all keys / feeder ids for various feeders in a text file, and saved the file. This is now copy-paste commands from that file into SSH terminal.


You may be able to fix this by manually deleting /etc/kernel/postinst.d/initramfs-tools-hack and /etc/kernel/postrm.d/initramfs-tools-hack, then retrying the upgrade. piaware (sdcard) 3.6.3 should remove these files on upgrade anyway, but getting to that point when you’ve got a broken system is the issue…


I do it by an automated installation script I have prepared for myself. I have now posted it here:




I have a problem after upgrading to 3.6.3 on raspbian stretch.

dump1090-fa runs fine and I can see the new skyview map, however piaware won’t start.
When I type in trough ssh:
piaware I get “illegal instruction”

Tried sudo apt-get purge piaware
Reinstall trough the method described here:

It installs without any errors, but after reboot I still have the same problem, It won’t boot up automaticly and manual command piaware of sudo piaware gives “illegal instruction”

Where should I look to fix this problem?