FlightAware Discussions

Announcing PiAware 3! (Latest version: 3.7.1)


By me it’s like this :

But my “style.css” was changed by myself in 3.6.2, I copied it back from the original of 3.6.2 (that I kept under a different name).
Is the style.css the same in 3.6.2 as 3.6.3 ?
If not how to get the original of 3.6.3 ?


Installing the current version should overwrite the html folder.

Did you try CTRL-F5 ?


Upgrade via the My ADS-B page to 3.6.3 is already available.


got it from github (clicked on 3.6.3) did copy paste from the file there


Remote upgrade of my 2 stations completed error free.

1 Like

just upgraded via the ads-b page, worked great

1 Like


I use a big screen so it is not too bad not having the floating panel BUT some important (to me) data is now off screen.

Most importantly, as my interest is mainly improving range, aircraft and message count, I cannot easily see the RSSI, Message count and Last Seen.

I cannot see RSSI and Distance at the same time.

And the really big anomaly is that if I am looking at RSSI or distance there is nothing visible to tell me which plane I am looking at.

Adding RSSI, Last Seen and Distance to the popup when I hover over an aircraft would probably solve all these shortcomings and be a really worthwhile enhancement.

Thanks for the good work,




I resized the bottom panel and now it has disappeared and I cannot seem to get it back.



All fixed.

It came back when I clicked on another aircraft.



Update via web page:

[2018-09-17 21:34 EDT] run-apt-get(7449): Restarting lighttpd…
[2018-09-17 21:34 EDT] run-apt-get(7449): E: Write error - ~LZMAFILE (28: No space left on device)
[2018-09-17 21:34 EDT] child process 7449 exited with status EXIT 1
[2018-09-17 21:34 EDT] aborting upgrade…
[2018-09-17 21:34 EDT] update request complete

Manual update via: sudo apt-get dist-upgrade:

Processing triggers for systemd (232-25+deb9u4) …
Processing triggers for man-db ( …
Setting up libraspberrypi0 (1.20180910-1) …
Setting up curl (7.52.1-5+deb9u7) …
Setting up libraspberrypi-doc (1.20180910-1) …
Setting up libraspberrypi-dev (1.20180910-1) …
Setting up libraspberrypi-bin (1.20180910-1) …
E: Write error - ~LZMAFILE (28: No space left on device)

Checking the space:>

pi@raspberrypi:~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 15G 1.8G 13G 13% /
devtmpfs 460M 0 460M 0% /dev
tmpfs 464M 4.0K 464M 1% /dev/shm
tmpfs 464M 25M 440M 6% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
tmpfs 512M 4.0K 512M 1% /tmp
none 1.0M 1.0M 0 100% /var/log
/dev/mmcblk0p1 43M 22M 21M 52% /boot
tmpfs 93M 0 93M 0% /run/user/1000

It’s the dreaded boot partition! What can I clean in there?


Do you normally update via the web page? The reason I ask is because I used to have this problem after a number of web updates.

It has not happened since adopting the re-image routine.

Today’s web update was only because I was away from home and wanted to try it right away, but I have now downloaded the image, and will return to my re-image routine when the need arises.


I don’t want to re-image the thingie. I remember seeing here someone complaining that the boot partition was getting full, but I don’t remember where or how it got solved.


You have same approach as mine. In my opinion, a fresh install is clean and headache free in the long run.

I always upgrade by writing latest image, either Piaware SD card, or Raspbian + dump1090-fa and piaware package install.

However for those whose Pis are not easily accessable, either at odd location, or far away, upgrading by ssh command or command from FA stats page is a very handy, and sometimes only practical solution


That is likely not the problem.

Your /tmp partition is a ramdisk that is most likely too small.
Try unmount /tmp with umount /tmp and try the install.
Remove it from fstab and reboot and then try the install.

EDIT: After looking at it again: It’s could be the /var/log tmpfs limited to 1M.


In fstab I made the /tmp as tmpfs (in RAM) to minimize the writes on SD and /var/log as none.
I’ll play with them.
LE: Shoot, stupid me, I commented (#) the /var/log and now is not booting anymore :frowning:
I guess I’ll go with a fresh image now.


That should not cause it to not boot. I mean it booted before you put that there? :stuck_out_tongue:

Anyway just download yourself a small USB stick linux, boot it on your main computer and you can mount the root partition and just change it back :wink:

Ok it’s not super simple but it’s not super hard either.


I’m up and running again with a fresh install. Was easier :wink:


Works every time.:joy:


FWIW, the problems with space in /boot should be fixed in the 3.6.3 image, and for upgrades from 3.6.2 that hadn’t already hit the problem.


That’s great!!