FlightAware Discussions

Announcing PiAware 3! (Latest version: 3.7.1)

Have you enabled Mode A/C in piaware-config? The default settings do not enable Mode A/C.

1 Like

It appears to be the default setting Oliver:

Should PiAware enable reception of Mode A/C messages when requested?

You may need to disable this if processing Mode A/C overloads your receiver.

allow-modeac yes

Ah, sorry, I forgot I made it on-demand. Planeplotter (or whatever else you connect with) needs to request Mode A/C by sending an appropriate Beast config command to dump1090 (0x1a ‘1’ ‘J’ - see http://wiki.modesbeast.com/Mode-S_Beast:Data_Input_Formats)

You can force always generating Mode A/C by passing --modeac to dump1090-fa, but there is no config setting that will do that on the sdcard image.

I just found running “view1090-fa --modeac” works.

Yep. view1090 will send the config command in that case.

Wow! Now highest ever message rate @ 2200+! Will that be implemented in the next build please?

Outside DPD, standard rtl-sdr dongle with an FA filter.

It appears to have a higher message rate than my Mode-S Beast …

Hugh

i’m not a linux driver, can you advise full command to turn mode ac on
thanks (i have a rpi 3b running piaware, will mode ac work with this configuration?)

Try this
sudo piaware-config allow-modeac yes

Check with
sudo piaware-config -show

sudo systemctl restart dump1090-fa
sudo systemctl restart piaware

jon, thank you very much

gw4xxj, could you provide full linux command line you used(i’m not a linux driver) for enabling mode ac?

retman1222, I just typed “view1090-fa --modeac” on the command line. It is not very satisfactory in that you need to leave the window open.

@gw4xxj @retman1222
Just type in
sudo view1090-fa --modeac &

and it will run in the background and you can close the terminal

adding the
&

Works for other processes also btw :wink:

I still keep learning about linux lol :slight_smile:

1 Like

I’m btw not exactly sure what modeac will do, sure it increases the message rate. However the planes with and without positions stays about the same.

Maybe someone can (simply :stuck_out_tongue: ) explain?
Is this only usefull if you use another viewer other then the (local) skyview page?

Doesn’t work here unfortunately …

Kind Regards

Is there a way to add this to the startup code on the Pi?

Hugh

see reply from katwijk several posts above re command sudo view1090-fa --modeac &

2 Likes

I’am not to good at linux, but this seems to work too
(untill you do a reboot)

(Background is from that post above, I tested this with the below instructions and this works with me.
There is also more info, but didn’t checked everything out.

You could try just the commands below, it;s harmless and you can remove the package “screen” easy with
sudo apt-get purge screen

anyway this works for me, is this useful in my situation? I don’t know. :smiley:
But it works. Maybe for people who use planeplotter. (see @abcd567 post below)

Anyway no harm to try this ->

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install screen

Next start screen:
screen

run
sudo view1090-fa --modeac

press
ctrl + shift + a

press
d

It should exit and keep running

To get back to the process run (this will work even if you close the ssh session remotely and reconnect later)
screen -r

Then if you want to stop the process just use
ctrl + c

edit:
to see processes running through screen type
screen -ls

Not to sure, it’s a little bit unclear what is running but you can at least see what’s running trough screen in the background.

More in the link, I didn’t go any further into it for now

1 Like

To start view1090-fa in modeac at boot/reboot, try this method (un-tested, as I dont have Planeplotter)

(1) Create new file view1090.sh

cd ~/
sudo nano view1090.sh

(2) Copy-paste following code in new file

#!/bin/bash
/usr/bin/view1090-fa  --modeac &

(3) Save (Ctrl+o) and Close (Ctrl+x) the file

(4) Make new file executeable

sudo chmod +x view1090.sh

(5) Open file /etc/rc.local for editing

sudo nano /etc/rc.local

(6) Copy-paste following code just above last line (i.e. above exit 0)

/home/pi/view1090.sh &

(7) Save (Ctrl+o) and Close (Ctrl+x) the file

(8) Reboot Pi
sudo reboot

@abcd567

Can you tell me more about mode AC?
Is this usefull for something if you don’t have planeplotter etc running?
It seems not to send the increased message rate to flightaware or other sites.

Also in skyview I don’t see really more planes with positions. Only increased messages/second

thanks :wink:

(btw you made a little typo in (5) etc not erc :slight_smile: just saying before people just copy/paste :smiley: )

I am not sure, but I think the above workaround to start view1090-fa is normally not needed/useful if you dont feed Planeplotter. The modeac is enabled by default. This is confirm by output yes of this command:

pi@piaware:~ $ sudo piaware-config --show allow-modeac
yes

Thanks, typo corrected.