FlightAware Discussions

Announcing PiAware 3! (Latest version: 3.6.3)


#926

No after the first line :stuck_out_tongue:
Search for the first line and add the second line after (first line is already in the file.)

Edit: I’ve made the post a little clearer


#927

How do I save the split between map and the list?
It keeps “hiding” the RSSI - either I have to scroll or enlarge slightly the vertical split.


#928

In file style.css find the following:

#sidebar_container

Directly below change the width so it reads:

    width: 550px;                                                                                                                      

Not sure which is the appropriate width you may have to try a larger value :slight_smile:


Change Width of Table in SkyView
#929

That works perfectly on my 1920x1080 monitor!


#930

Hi wiedehopf,

After adding //showColumn(infoTable, “#rssi”, !mapIsVisible);
The RSSI is shown right after the Age column, everytime I have to move the map divider slider to suit the width of the table. Any solution to fix it? It will back to its default divider after every refresh or newly open the skyview map, thanks for the sharing info.

Best regards,
Sai Hou
WBKK


#931

Scroll up 2 posts above yours :slight_smile:


#932

Hi wiedehopf,

Its my mistake, overlook the page. Which is shown above my post. Thanks again for the info.

Best regards,
Sai Hou
WBKK


#933

Is there anyway of upgrading a PiAware (SD Card) 3.5.3 installation to 3.6.3 via ssh, without having to physically access the RPi (to swap or update via the SD card?

I have tried a few commands but nothing!


#934

You should be able to to tell it to upgrade from the FA stats page (https://flightaware.com/adsb/stats/user/bidgee -> paddle wheel).
Then the drop down menu will offer a choice of upgrades.


#935

Done that but didn’t work.


#936
sudo apt-get update
sudo apt-get upgrade

That should do it.


#937

That didn’t work at first, reason was I kept getting
pi@piaware:~$ sudo apt-get update
E: The method driver /usr/lib/apt/methods/https could not be found.
N: Is the package apt-transport-https installed?

This required to use the wget to get apt-transport-https, which has fixed the whole update issue but now running into this (below)

[2018-12-23 10:07 AEDT] run-apt-get(22749): Some packages could not be installed. This may mean that you have
[2018-12-23 10:07 AEDT] run-apt-get(22749): requested an impossible situation or if you are using the unstable
[2018-12-23 10:07 AEDT] run-apt-get(22749): distribution that some required packages have not yet been created
[2018-12-23 10:07 AEDT] run-apt-get(22749): or been moved out of Incoming.
[2018-12-23 10:07 AEDT] run-apt-get(22749): The following information may help to resolve the situation:
[2018-12-23 10:07 AEDT] run-apt-get(22749): The following packages have unmet dependencies:
[2018-12-23 10:07 AEDT] run-apt-get(22749): piaware : Depends: libreadline7 (>= 7.0~beta) but it is not installable
[2018-12-23 10:07 AEDT] run-apt-get(22749): Depends: libssl1.1 (>= 1.1.0) but it is not installable
[2018-12-23 10:07 AEDT] run-apt-get(22749): E: Unable to correct problems, you have held broken packages.
[2018-12-23 10:07 AEDT] child process 22749 exited with status EXIT 1
[2018-12-23 10:07 AEDT] aborting upgrade...
[2018-12-23 10:07 AEDT] update request complete

#938

Seems like the newer piaware depends on newer libraries which are not available in the old debian version.
There is a problem with doing dist-upgrade because of the boot partition being too small.

Best bet is to do flash it to the sd-card. (This shouldn’t be necessary in the future)


#939

Generally the “Is the package apt-transport-https installed?” thing means that the normally HTTP download for package metadata is getting redirected to a HTTPS URL, which is unusual. It either means you’re getting sent to a misconfigured mirror site, or (more common) your network requires some sort of authentication and the download attempt is getting redirected to a captive portal login of some sort.

Seeing the full upgrade logs, not just the end of them, would be helpful.


#940

Sadly the RPi or the SD card just failed. Not able to test this until tomorrow (Boxing Day/Dec 26th).

I do know that looking at the mirror list, they were all http, since https kept getting stuck in loops.


#941

Checking running processes on my piaware, I found lxpanel, Xorg, and lightdm. I remember this being a command-line-only install. So did one of the updates get messed up and install all the GUI stuff? I did it one time in the past by doing a dist-upgrade I think, but I’ve let it auto-update itself since I fixed it and learned my lesson. It runs noticably slower with the GUI elements and I do not use them.


#942

Yes, I think it is based on the stretch light version of raspian.

I had a quick look with top, those processes are not running on my RPi. It has the current version of piaware, but I reinstalled when it changed from Jessie to Stretch. However I did a apt-get upgrade only recently.

How did you fix it when you did a dist-upgrade, and how do you notice your Pi is slower?


#943

I notice when viewing the local webpage it is slower to load and update. I also see a lower position count and increased memory usage in top.

When it happened the first time I just reimaged the SD card and started over, I’d like to avoid that this time around.