FlightAware Discussions

Announcing PiAware 3! (Latest version: 3.6.3)


#722

Oh, I did not realize it pertained to auto-pilot.
Now I checked and found the glitch is still there in 3.6.2bis version


#723

I’m on the original 3.6.2. is there anyway to update whats changed from 3.6.2 to 3.6.2bis without full re-image?


#724

If your original 3.6.2 is running fine, there is no need to update. But to do so, without re-imaging, either do it from the My ADS-B page, or manually issue a sudo apt-get update, followed by a sudo apt-get upgrade command.


#725

The only difference between the two images is the contents of /etc/hosts so you can just edit that by hand if it’s causing problems. The packages etc did not change.


#726

Not a big deal, but it was a handy feature to display name piaware when microSD card was slipped into desktop/laptop.

Now it displays boot, just like raspbian image. Cant diffrentiate weather it is piaware image or respbian image unless folder /boot is opened and contents checked.

piaware-boot


#727

I upgraded to 2.6.2 shows in the dialog that its tracking data but the flightaware web page under flights with positions i havent seen anything new since the upgrade…i probably broke something somewhere here is the latest read out

its my my system ive been using on here for the last couple of years

I currently am not local to the piaware…im at work

[2018-07-30 11:15 EDT] mlat-client(969): Beast-format results connection with 127.0.0.1:30104: connection established
[2018-07-30 11:21 EDT] mlat-client(969): Receiver: 159.2 msg/s received 50.3 msg/s processed (32%)
[2018-07-30 11:21 EDT] mlat-client(969): Server: 0.3 kB/s from server 0.0kB/s TCP to server 0.6kB/s UDP to server
[2018-07-30 11:29 EDT] 5206 msgs recv’d from dump1090-fa (1067 in last 5m); 4971 msgs sent to FlightAware
[2018-07-30 11:36 EDT] mlat-client(969): Server: 0.3 kB/s from server 0.0kB/s TCP to server 0.7kB/s UDP to server
[2018-07-30 11:36 EDT] mlat-client(969): Results: 147.2 positions/minute
[2018-07-30 11:36 EDT] mlat-client(969): Aircraft: 21 of 48 Mode S, 27 of 30 ADS-B used
[2018-07-30 11:39 EDT] 7352 msgs recv’d from dump1090-fa (1071 in last 5m); 7117 msgs sent to FlightAware
[2018-07-30 11:44 EDT] 8456 msgs recv’d from dump1090-fa (1104 in last 5m); 8221 msgs sent to FlightAware


#728

This is a known server-side problem that we’re in the process of fixing. The data is being received fine, it’s just a problem with displaying it.


#729

Thanks for the quick reply


#730

Same problem here. Good to hear that you are working on it. :slight_smile:


#731

You can always rename the card to give a meaningful name.

As soon as I’ve burnt an image, I start to customize it. Once it has the UniqueID, the card becomes site specific, so needs a name to reflect this.


#732

Did the update via the configure menu on the adsb feeder statistics page last Saturday, and now notice a drop in aircraft counts by approximately 30-40%. MLAT is enabled and working, and gain set to -10 (AGC) using the flightaware pro-stick +. This is an RPI3B Piaware image.
Should I be playing with the gain setting to bring counts back up? Always seemed to get good results using the -10 setting until the update.

My other feeder is on a RPI2B, installed a new piaware image when updating and added MM2. It uses a yellow pro-stick (not the plus with the filter and amp). Plane counts do not seem to be affected by the update on this install.

edit: Funny after leaving this message my aircraft count went back up again… :slight_smile:


#733

My upgrade (via the page) has removed altitude & speed too!

hjm


#734

@hughjmilsom Please do a hard refresh of the Skyview page in your browser to load the latest software.


#735

Still nothing. I’ve removed the Safari cache for Flightaware …

Kind Regards

Hugh

HUGH MILSOM
FUNERAL CELEBRANT
Tel: 01793 721414
hmilsom
Mobile: 07798610482 hugh_milsom
Email: hugh@swindonfuneralcelebrant.co.uk

Website: www.swindonfuneralcelebrant.co.uk

If you do not want to receive emails from me in the future, please send an email with UNSUBSCRIBE in the subject and I will remove your details from my records.


#736

It’s the same on Safari & Firefox …

Kind Regards


#737

Yippee! Absolutely no idea what or why but it’s fine!

Hugh


#739

Hi Bram,

I have the same problem with VRS after the update, what did solve your problem?
Is it a hard reboot or was it changing the /etc/hosts file?
If I take a look in VRS, I only get “bad messages” from Piaware.

Regards,
Ton


#740

What port are you feeding from PiAware to VRS?

I took a look at the 30003 (old SBS-style) output from 3.6.2 and it looks like one of the timestamps is getting mangled; possibly this is causing problems for VRS.

30005 (Beast, which you should probably use anyway) should be fine.


#742

i’m a 31 day old user of flightaware and piaware (via SD card) currently using v 3.5.3 on a rpi3b. regarding the upgrade to 3.6.2 do i wait for the automatic update (i have "auto update PiAware software enabled on the feeder page) or do i do manually via the ADS-B feeder page…or do i do a new SD card ?

i apologize if this is evident, but, as noted, i am only 31 days old


#743

The ‘customer’ is always right. Your choice.

Some of us cannot wait, that’s all.:wink:

If you re-image the SD, don’t forget to copy and paste the feeder-id, or a new one will be issued.