The script which has to be used coming from FA website if you run already a Raspberry with a running Raspbian on it. So not the disk image you provide.
We don’t provide any install scripts on the FA website. Do you mean the package install instructions at https://flightaware.com/adsb/piaware/install ? I would not expect to see that problem if you used those instructions.
Script/Package, however you will call it
I’ve removed the file as instructed by you. Error is gone, this is the current status of apt-get upgrade:
The following packages have been kept back: mlat-client piaware 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
forget about the mlat client, that’s a different install
Unfortunately I can’t offer much support here - this system has obviously had a bunch of things done to it that aren’t from our side, and without a detailed description of what you installed and changed, in what order, and the full output of the upgrade attempt etc I can’t help. You may want to consider reimaging if you continue to have problems.
Well you’ll need to dist-upgrade instead of upgrade i suspect.
sudo apt dist-upgrade
Does that help?
sudo apt purge piaware sudo apt purge piaware-repository
Then do the install process again.
I would expect the piaware stretch repo was installed as the 3.8 repo package wasn’t available yet.
Maybe the bpo repo was then installed after that or something like that to spice it up a bit
piaware-repository 3.7.2 -> 3.8.0~bpo9 is the stretch upgrade path; both install
piaware-repository 3.8.0 is the buster path; it installs
piaware.list. That is only created by piaware itself if an upgrade is requested and the correct repository-package-installed sources file is not present.
So the only way I can see this happening is if at some point a piaware upgrade was requested when the piaware-repository package was not installed. Which does not match the current description of events, which was “3.7.2 was installed, then later updated”.
edit: Oh, ok. I think I see the path of events. This is a Pi 4, so it must be a Buster install, but it had 3.7.2 installed on it; so it had the stretch versions (piaware-repository 3.7.2, piaware 3.7.2) installed. An update would have installed piaware-repository 3.8.0~bpo9 and piaware 3.8.0~bpo9. Then a manual update request would have seen that
piaware-buster.list was missing and would have created the fallback list. So far, this is harmless because there’s
piaware.list present, and they have different contents; apt will be able to see both the Stretch packages and the Buster packages, and it will pick the Buster packages because they have a higher version number (3.8.0 > 3.8.0~bpo9)
Then, installing the Buster piaware-repository (3.8.0) explicitly would have removed
piaware-stretch.list and installed
piaware-buster.list. Now we have duplication between
tl;dr: it’s due to the unsupported combination of installing the 3.7.2 Stretch packages on Buster.
I’ve edited the top post FAQ about 3.7.2 buster installs to add a step for removing
piaware.list if it exists.
(ITT you get to see why mixing packages across distributions is a nightmare. I would be so happy if I only had one distribution to support…)
Yes, that made the trick:
Preparing to unpack .../piaware_3.8.0_armhf.deb ... Unpacking piaware (3.8.0) over (3.8.0~bpo9+1) ...
Yeah it’s not fun.
Anyhow it provides for interesting puzzles sometimes.
Well mostly they are kinda boring, but you have to take what you can get
+1 for PiAwareBSD 4.0.0
Would you happen to know roughly when 3.8.1 will be available please? No big deal and I’m not chasing. I’m reimaging before the weekend so if it’s imminent I’ll wait for it rather than work around the bug and then do an upgrade anyway.
It’s not imminent, I’d go ahead and reimage with 3.8.0