ADSBReciever image broken - cant update to PiAware 3.x?

Morning all,

Slight hiccup…

Have been running ADSBReceiver image successfully for many months - thanks JP! :slight_smile: .
However, with pA 3.x now out, thought i’d rerun the ADSBReceiver scripts to update to pA 3.x …

As warned here… … rsion-3-1/

That didnt work, tried to install 2.x over the existing, same 2.x.

Then I purged the pA altogether, and tried again…

The install routine through an error, looking at the detail, seems it couldnt find the pA repo, so I guess that’s moved?

I now have no pA period…

No issue - I appreciate maintaining an image is time consuming and not guarenteed - but what can I do from here?




Press enter to continue…Preparing the piaware_builder Git repository…

Entering the piaware_builder git repository directory…
Updating the local piaware_builder git repository…

You are not currently on a branch. Please specify which
branch you want to merge with. See git-pull(1) for details.

git pull <remote> <branch>

Building and installing the PiAware package…

Executing the PiAware build script…

Retrieving 6a883f428912357c252654cb811499e58db87d3a from
6a883f4 jessie’s c_rehash doesn’t like multiple certificates per file, split them out.
Retrieving 460debe4d350f06f9c7e54e5400992cac4f1d328 from
460debe Update
Retrieving faup1090-2.1-5 from
497f88f Don’t match faup1090 tags when generating a version string from git tags.
Retrieving v0.2.4 from
f68b8e3 v0.2.4
Ok, package is ready to be built in ./package
run ‘dpkg-buildpackage -b’ there (or move it to a Pi and do so there, or use pbuilder, etc)

Entering the PiAware build directory…
/home/pi/adsb-receiver/bash/feeders/ line 122: cd: /home/pi/adsb-receiver/build/piaware_builder/package-jessie: No such file or directory
Building the PiAware package…

tail: cannot open ‘debian/changelog’ for reading: No such file or directory
dpkg-buildpackage: error: tail of debian/changelog gave error exit status 1

Installing the PiAware package…

dpkg: error processing archive /home/pi/adsb-receiver/build/piaware_builder/piaware_.deb (–install):
cannot access archive: No such file or directory
Errors were encountered while processing:

Checking that the piaware package was installed properly…


The package “piaware” could not be installed.

PiAware setup halted.


OK, used the “package based installation” instructions from pA… pA instance reports as being 3.x as hoped.

However, accessing the ADSBReceiver web UI shows the live map etc broken - no live tracking etc.

As feared, I guess the standalone install of pA doesnt integrate with ADSBR as it expects…

Will try and re-install the other aspects of ADSBR (everything except pA) and see if that fixes it…

Hmmmk… looks like the Performance Graphs in ADSBR may be working - I’ll let it run to get better granularity and confirm.

That said, live maps arent showing any birds, I believe that may be a change in dump1090-mut , I do recall there was some discussion re mapping services etc some time back, but I didnt take note as I wasnt looking to upgrade at the time…?