Adding VBFZ-1065-S+ filter kills Dump-mut


#1

So, I finally decided to get a filter for the antenna. I went with the Mini Circuits VBFZ-1065-S+ .

I shut everything down…Install filter and reboot. Dump1090-Mutability will not run. It claims there is no RTL dongle. Running lsusb shows it. If I then remove the filter, upon reboot, everything starts up normally and is happy.

What am I missing? Are these filters directional?

Here are the logs:

With filter installed-


genericuser@antenna /var/log $ tail dump1090-mutability.log
CPU load: 26.6%
  673251 ms for demodulation
  227414 ms for reading from USB
  55458 ms for network input and background tasks
Fri Apr 10 18:02:56 2015 EDT  Caught SIGTERM, shutting down..

Fri Apr 10 18:03:13 2015 EDT  dump1090-mutability v1.14 starting up.
No supported RTLSDR devices found.
Fri Apr 10 18:51:58 2015 EDT  dump1090-mutability v1.14 starting up.
No supported RTLSDR devices found.
genericuser@antenna /var/log $ lsusb
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 018: ID 2109:2811  
Bus 001 Device 022: ID 148f:5372 Ralink Technology, Corp. 
Bus 001 Device 021: ID 0bda:2832 Realtek Semiconductor Corp. RTL2832U DVB-T
genericuser@antenna /var/log $ 

Normal/With NO filter-


genericuser@antenna /var/log $ tail dump1090-mutability.log
No supported RTLSDR devices found.
Fri Apr 10 18:51:58 2015 EDT  dump1090-mutability v1.14 starting up.
No supported RTLSDR devices found.
Fri Apr 10 19:04:58 2015 EDT  dump1090-mutability v1.14 starting up.
Found 1 device(s):
0: Generic, RTL2832U, SN: 77771111153705700 (currently selected)
Found Rafael Micro R820T tuner
Max available gain is: 49.60 dB
Setting gain to: 49.60 dB
Gain reported by device: 49.60 dB
genericuser@antenna /var/log $


Link to photo of setup


#2

I’d check dmesg for anything odd from the USB subsystem (disconnect messages etc). I’d speculate you actually have a bad connection somewhere and disturbing the dongle when you change the filter is enough to jiggle the bad contact… Can’t see how adding a passive filter on the antenna side could possibly affect the dongle’s USB bits otherwise.


#3

I moved the RTL to different ports on the hub. WiFi is though the hub, so the hub was working correctly, otherwise I wouldn’t be able to SSH in. I don’t see anything odd in dmesg right now (currently reverted to working configuration).
Will the RTL dongle “go offline” if it doesn’t have an antenna attached?

Should I be able to ohm these filters? Center pin to center pin, female center to shield, male center to shield are all open. This doesn’t seem right to me. Only female to male shield (the body) have good continuity.

The specs are:
http://www.minicircuits.com/pdfs/VBFZ-1065+.pdf


#4

i have used one of those filters without any problems, that being said if you can check the filter for a dead short across its connector. This is about the only thing i can think that would bring down the dongle.


#5

No… you just won’t see any messages :slight_smile:


#6

On the Specification sheet the functional schematic shows a capacitor at the female end. That will keep you from reading
any continuity from the male center pin to the female center pin.


#7

Well, I tried again swapping it out live. It seems to be working now. I guess the USB was intermittent. Did a reboot and everything still worked as needed.

Hopefully I’ll have improved results. Time will tell!


#8

It’s looking like the filter setup is reducing the number of positions reported compared to my history and relative to jepolch feed. I guess I’ll try adding an amp. The cable run is only 4 feet.

When adding an amp, are there any configuration changes needed for dump1090-mut?

Which is consider best/correct?
antenna -> filter -> amp -> power injector -> RTL
or
antenna -> amp -> power injector -> filter -> RTL


#9

If your amp can handle the signals i would opt for having the amp first. At 1090MHz the filter adds a loss of 1.75 dB (roughly the same as 5m RG58 coax at 1090Mhz). However if it’s a bad amp it might introduce interference which can cause trouble. I’ve had good results with LNA4ALL and G4DDK amplifiers before the filter.
With a large amplifier gain (+35dB) i’ve found that lowering the RTL gain to around +20dB improved the message rate. Don’t use AGC but try some fixed values.
/paul


#10

I had a similar problem and deduced that my USB hub wasn’t giving the receiver enough power.

Which hub are you using?


#11

An Amazon branded powered hub. The hub is fine. It powered it for 145 days before I added the filter. There was some moisture buildup in the enclosure. It must have lightly corroded contacts just enough that it could identify the dongle, but not much else.

I’m going to give the “Perfect Vision In-Line PVLA-30 Satellite Amplifier 30dB Gain 950-1750MHz” a try. I would like to not remove the filter, if nothing more because it cost $40 plus shipping.


#12

But if the filter has no DC continuity, then there would be problems powering the amp up the wire … so the filter would need to come first (or after the power injector)


#13

Good catch! The filter does block DC so the setup could be like:
antenna -> amp ----cable----> power injector -> filter -> RTL
/paul