cannot be found during upgrade

One of my several feeders has been up and running for almost 900 days and I know I have not touched it much since 2017. Today I decided to run sudo apt full-upgrade as suggested here. I’m a linux noob but it appears as if may be hard-coded and cannot be reached. Multiple “failed to fetch” errors. Is there another way to update everything?

Not sure if this is your problem or not, but I recall something about the RasPi repositories moving or being renamed for old versions when I was doing an upgrade from a really old level, which is what you are looking at with 2017.

Did you try:
Sudo apt update
Sudo apt upgrade

Neither approach will upgrade you to the current raspberry Pi OS though. In the long run, You might be better of to start with the most current fresh image with a system as old as that.

1 Like

Good suggestions. TU @Jranderson777 . I tried update/upgrade first and those failed. Then I tried the “full upgrade” route. Just trying to apply whatever OS updates may have been issued – particularly those related to security. The “bad IP address issue” appeared when trying to update the FA software – not the OS.

I agree that a complete rebuild may make more sense. And, if the feeder was not in an inaccessible location (but highly productive) I’d do that. Actually, if I can’t do this remotely via SSH I think the best solution will be to drive three hours to the site and then “repurpose” the pi.

Why not just leave it as is if it is working?

I have remote sites and if it is working I don’t risk breaking it.

I leave well alone until someone is heading in that direction and get them to just replace the microSD card with one that is up-to-date and pre-tested.



1 Like

SweetPea11’s idea has merit, especially for remote sites!

Here are the contents of my /etc/apt/sources.list file. It might give you a hint as to your problem. I built the system starting with the FA image, not the standard Raspberry Pi OS. It’s also Buster, which will be more current than your 2017 OS. I also feed FR24 (you can see the repo) and adsbexchange, not showing here because they don’t do an apt install.

pi@piaware:~ $ cat /etc/apt/sources.list
deb http://flightaware.com/mirror/raspbian/raspbian/ buster main contrib non-free rpi
# Uncomment line below then 'apt-get update' to enable 'apt-get source'
#deb-src http://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
deb http://repo.feed.flightradar24.com flightradar24 raspberrypi-stable
pi@piaware:~ $

Please provide the full output including the error message.

@obj, @Jranderson777 & @SweetPea11: Thank you for your suggestions. I’m no longer able to capture the many lines of errors and I think the best strategy is to get out of the feeding business. I’d love to know what the issue was with, owned by the Univ of Texas system, but I guess I’ll let it rest and move on to other things. Again, I appreciate your responses.

The IP points to webfarm.flightaware.com. I can get to it from Tampa, FL but it is very slow at ~100 ms. Yesterday pings from here timed out.

So one setback in updating one remote feeder and you’re going to quit ADS-B feeding altogether? Lame. (note that this is not the same as the IP address you originally mentioned) is (www.)flightaware.com, i.e. the main FA webserver. That IP is part of FlightAware’s address allocation, not the University of Texas. is part of the UoT allocation - I guess you made the same typo when looking at whois. apt will be trying to fetch a package or package metadata from the FA webserver as part of the update process – this is normal – I’d need to see the exact error to work out what’s going wrong.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.