All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: MLAT Anomalies
PostPosted: Thu May 04, 2017 3:57 pm 
Offline
sebgray - FlightAware user avatar

Joined: Mon Mar 09, 2015 3:51 am
Posts: 5
So that 3 of us with a Pi 2 that gives timing errors for M-LAT with kernel version 4.9.x that was resolved by downgrading to 4.5.x... I've no idea why either but I can live with that as I'd rather have stability. I'll continue to update the Pi software as normal however I'll not be running rpi-update for a while! :roll:


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Thu May 04, 2017 5:05 pm 
Offline
FlightAware Staff
obj - FlightAware user avatar

Joined: Tue Sep 30, 2014 7:14 pm
Posts: 3463
You might want to report the problem upstream to the Pi Foundation

(timing errors generally mean that USB traffic is being dropped, presumably in the kernel's USB stack in this case)


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Sun May 07, 2017 12:31 pm 
Offline
g7ruh - FlightAware user avatar

Joined: Thu Oct 02, 2014 5:31 am
Posts: 3
sebgray wrote:
So that 3 of us with a Pi 2 that gives timing errors for M-LAT with kernel version 4.9.x that was resolved by downgrading to 4.5.x... I've no idea why either but I can live with that as I'd rather have stability. I'll continue to update the Pi software as normal however I'll not be running rpi-update for a while! :roll:



And another one which makes 4. I upgraded to a yellow flight stick and dump1090-mutability and had a huge increase in position reports that I had to upgrade to a Pi2 (CPU overload in the PiiB). I thought it was the increase in volume that triggered the mlat issue, until I saw this thread. I downgraded to 4.5.x and it has been running fine for the last 5 hours.

I guess it is an issue that the dump1090-mutability folks should take up with the pi firmware folks.

Is anyone using a Pi 3 getting these issues??

thanks for the pointer sebgrey 8)


EDIT with update: after 2.5 days using the 4.5.x firmware MLAT is still working very well, no drops at all :D

Roger


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Thu May 11, 2017 6:14 pm 
Offline
FlightAware Staff
obj - FlightAware user avatar

Joined: Tue Sep 30, 2014 7:14 pm
Posts: 3463
Some possibly related issues: https://github.com/raspberrypi/firmware/issues/753 https://github.com/raspberrypi/linux/issues/1998


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Fri May 12, 2017 3:23 am 
Offline
FlightAware Member
conligwx - FlightAware user avatar

Joined: Sat Mar 18, 2017 8:00 pm
Posts: 88
Location: EGAC/EGAD
g7ruh wrote:

Is anyone using a Pi 3 getting these issues??

Roger


I have a 2nd pi3 running 4.9 Kernel/piaware v3.50 and it seems ok, been running it for about 3-4 days with the new kernel.


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Sat May 13, 2017 3:58 am 
Offline
g7ruh - FlightAware user avatar

Joined: Thu Oct 02, 2014 5:31 am
Posts: 3
conligwx wrote:
g7ruh wrote:

Is anyone using a Pi 3 getting these issues??

Roger


I have a 2nd pi3 running 4.9 Kernel/piaware v3.50 and it seems ok, been running it for about 3-4 days with the new kernel.


thanks, that confirms my findings:

I have replaced the offending Pi 2 with a Pi 3 and the 4.9.x kernel and it has been working fine for 3 days, so it seems to be a Pi2 only issue. I will use the P2 elsewhere.


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Tue May 16, 2017 10:27 am 
Offline
Dudley - FlightAware user avatar

Joined: Fri Dec 16, 2005 1:00 pm
Posts: 2
I have 2 RPi 2 that experienced this problem after upgrade to 4.9 & resolved when downgraded to 4.5

sebgray wrote:
So that 3 of us with a Pi 2 that gives timing errors for M-LAT with kernel version 4.9.x that was resolved by downgrading to 4.5.x... I've no idea why either but I can live with that as I'd rather have stability. I'll continue to update the Pi software as normal however I'll not be running rpi-update for a while! :roll:


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Wed May 17, 2017 5:01 pm 
Offline
MatthewZinicola - FlightAware user avatar

Joined: Sun Aug 02, 2015 6:01 pm
Posts: 10
I suffered this issue on a high-profile/high-traffic (remote) piaware site of mine. I was going crazy trying to figure it out (my raspbian upgrade coincided with my upgrade to 3.5.0 and other changes)...

Sincerest thanks to the folks that figured this out, determined the solution and posted it...!! :D


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Wed May 24, 2017 6:43 am 
Offline
phg2k - FlightAware user avatar

Joined: Wed Dec 09, 2015 7:49 pm
Posts: 10
Reverting Kernel worked for both my PIs...
Not great, but at least working.

Many thanks!


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Wed May 24, 2017 7:57 am 
Offline
KarlNapf - FlightAware user avatar

Joined: Tue Mar 08, 2016 8:27 am
Posts: 6
sebgray wrote:
So that 3 of us with a Pi 2 that gives timing errors for M-LAT with kernel version 4.9.x that was resolved by downgrading to 4.5.x... I've no idea why either but I can live with that as I'd rather have stability. I'll continue to update the Pi software as normal however I'll not be running rpi-update for a while! :roll:

add +1 to the statistics:
Pi2 MLAT clock stable with kernel 4.4.50 but not 4.9.xx
Pi3 MLAT clock stable with kernel 4.9.29, too.


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Wed May 24, 2017 2:15 pm 
Offline
FlightAware Member
Radiostationx - FlightAware user avatar

Joined: Mon Nov 24, 2014 2:52 pm
Posts: 179
+1

Listed on Github

https://github.com/jprochazka/adsb-rece ... -303758098


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Wed May 24, 2017 6:39 pm 
Offline
tonyscanga - FlightAware user avatar

Joined: Sun Aug 07, 2016 5:45 pm
Posts: 6
I have some anomalous MLAT data. On May 18th, I got a spike in MLAT position reports and since then, the number has tanked. Its been relatively constant for months. Also, the number of airplanes has remained relatively constant even as the number of reports has dropped off the table.

I'm not sure what is going on. Any insight as to cause. I uses the standard FA 3.1 SD card. This behavior is the same on both of my sites, so I don't think its related to my system or configuration.

Thanks

Tony


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Wed May 24, 2017 6:46 pm 
Offline
FlightAware Staff
obj - FlightAware user avatar

Joined: Tue Sep 30, 2014 7:14 pm
Posts: 3463
tonyscanga wrote:
standard FA 3.1 SD card

Upgrading to 3.5.0 would be a starting point.


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Sun May 28, 2017 6:04 pm 
Offline
tonyscanga - FlightAware user avatar

Joined: Sun Aug 07, 2016 5:45 pm
Posts: 6
Upgraded one of my sites to 3.5 and No Joy. MLAT stats are still much lower than over the last 10 months.


Top
 Profile  
 
 Post subject: Re: MLAT Anomalies
PostPosted: Sun May 28, 2017 6:44 pm 
Offline
FlightAware Staff
obj - FlightAware user avatar

Joined: Tue Sep 30, 2014 7:14 pm
Posts: 3463
Your receiver probably moved from a pair of regions (near their border) to a single region when the regions were expanded.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 40 posts ]  Go to page Previous  1, 2

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: Akissack, davewill2010, Google [Bot], rjbiii13 and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to: